Back to the Shapespark home page

Application error topics:Communication error

When I try to log in with the desktop application
I get an error and it does not work properly.

Our Internet administrator has investigated the packets.
As a result, we were able to confirm that the proxy set in Internet Options is not being used when using this application.

So my question is, does this application
Does this application support the use of proxies?

Also, are there any other URLs that should be allowed in the firewall other than the ones answered in the following URL?

*ttps://forum.shapespark.com/t/communication-error/2754

cloud.shapespark.com
storage.googleapis.com

This error only occurs in the Destop application.
In a web browser, the error does not occur. It works normally.

Shapespark supports HTTP and HTTPS proxies. It reads the proxy address from HTTP_PROXY and HTTPS_PROXY environment variables. Could you check if one of these variables is set for the user or computer?

The proxy address you are using is set to an address starting with “http://”.

The same error occurs when I set the following URLs to be allowed in the proxy exception settings

cloud.shapespark.com
storage.googleapis.com

If you are using http:// proxy, then please add HTTP_PROXY=http://... environment variable. Please, log out and log in to your Windows account after making this change.

Thank you for your answer.I’ll check it out.

As another example, if I am using a proxy address that does not use “HTTP” and “HTTPS”, is there anything I can do about it?

Could you ask your Internet administrator what proxy type it it? It might be that Windows settings may silently assume the proxy is HTTP one if the protocol is omitted.