Back to the Shapespark home page

Bake doesn't look like preview

Hello,
I am having some problems with my latest shapespark project. After baking, some of my textures change in color (the floor tiles in this example). I have tried baking on super and the problem persists. I have also tried to remove the light probes in those areas which also did not solve my problem. I also tried changing the flood dark limit, I have tried values: 0.02, 0.03, 0.04, and 0.08. Any ideas?

After bake:


(I can only upload one image at the moment but the light brown areas on the edges of the wood should not be there. They don’t appear in the preview render)

Any help/ideas are very appreciated!

It looks like a texture compression issue. You could verify it by appending #nobasis at the end of the uploaded scene URL and see if the problem is gone. The upcoming release will allow to disable texture compression for individual textures.

The problem still seems to persist after adding #nobasis to the end of my URL. Would it help to make the textures smaller? The floor tiles are 741x4756

Thank you for your fast response!

Changing the texture size rather won’t help. Could you share a link to this scene here or via support@shapespark.com?

Yes, the link is https://ryan-companies.shapespark.com/the_harper_02/

Thank you.

Just to clarify, do you mean these orangy wood edges?

image

https://ryan-companies.shapespark.com/the_harper_02/#nobasis does reduce the orange color, but it is not completely gone. Perhaps PNG to JPG compression also suffers from such problem.

Yes those are the textures that are incorrect. Is there anything on the texture side that I could change? I can change the texture file type

In the just released Shapespark version, you can disable texture compression and downscaling for this problematic texture with this button:

Awesome, thank you very much. I will try that out.
**edit
The new update fixed the problem. Thank you very much!