Back to the Shapespark home page

Blotchy renders at 2000+ samples?

Hey devs, fantastic product, we’re very happy with it and the recent feature updates.

Question about render samples and resolution. What are your recommendations for resolution and samples to remove blotchy shading spots as seen here? Guessing it’s a light cache / interpretive render samples issue or something. We’ve gone up to 3000 now and they’re still apparent.

Rendered with Lightmap res of 120 @ 2000 samples, Bounces 8, Flood dark limit 0.08.

Hi!

Such blotches are a result of noise, which the denoiser couldn’t handle efficiently. In most cases high noise is caused by light sources which are difficult to find by a path tracing renderer. Are you using any point (maybe also spot) lights hidden in lamp shades? If so, please try turning them off and bake the scene again; 800-1000 samples should be enough.

To decrease noise from light sources hidden in lamp shades you may apply a following trick: substitue a signle point light with two spot lights: one shining down and one up, such that each of the light sticks out the shade.

Great, that worked, thanks! Replacing the point lights with spot lights allowed me to render at much lower settings with lower noise. It begs the question whether pointlights are even usable if they cause so much artifacting/noise in the render.

I think there are scenarios where point lights are usable, for example a light bulb without a lamp shade. However, they are not the best option for lamp shades, where the light source is hidden.

Hi,
I baked the scene with default parameters, and one room has much more artifacts than other (blotches on the wall, pillows, curtain). Is it the lights or the the bake samples should be higher or both? Lights are spot lights in lamps. I would like your advice about the changes I should make to avoid the problem, since the render time is long, and I can not experiment much. Thanks!

Hi @vesna100, welcome to the forum.

Could you share a link to the scene, so we could take a closer look?

Such blotches are usually a result of noise caused by lights placed very close to some scene objects. It seems that in your case the spot lights may be hidden in lamp shades. Could you try lowering the lights, so they are outside the shades?

Another thing is that the darker a room is, the stronger (relatively) the noise is. So, while the default value: samples = 100 might be enough for the well-lit room, it is most likely to few for the darker room. I think you might need to increase it to 400 (this will increase the baking time approx. 4x).

Thanks for the quick response @wojtek! I tried to add more light, and move light source away form the lamp, and that works just fine. I will also try lower light and higher sample value, and let you know hot it turns out.