Back to the Shapespark home page

Horrible lighting artefacts

Hello can anyone help with these horrible lighting artefacts I’m getting on all surfaces, even flat surfaces. Even when I use the highest bake settings.

Thanks!
H

Muumimamma! :slight_smile:

Hi there. I’d try modifying the ‘Flood dark limit’ filter in the Bake tab. Try increasing it to 0,04 - bake and see what happens.

1 Like

@moominmomma, it looks that the denoiser was unable to remove the noise completely on some of the surfaces.

  1. What number of samples did you use for the bake?
  2. Do you have light sources placed very close nearby objects in this room? Very strong light reflections produced by such light sources can increase the noise.
  3. In general it’s more difficult to remove lightmap noise for thin surfaces. You may increase set Custom lightmap resolution in the Objects tab to a higher value than the default (75) for objects with artifacts. This way the object surfaces will occupy lager areas in the lightmaps, which will help the denoiser.

Hi Wojtek and Ville, thank you so much for taking time to help. I’ve spent the day experimenting with the bake settings. I’ve had some horrors! … But this is the best I’ve managed; not awful, but still the toilet has bad lighting, but only at the front!? I have a sky light, an Area light just inside the window, and a single spot above the bath. I’ve included the bake settings in the image. I also set the toilet custom lightmap settings to 200. I’ve checked smoothing on the model, and turbo smoothed to try and fix it but Ugh! Any ideas gratefully received!
H

… forgot to post the screeny!!

It looks that the top of the toilet cover is UV unwrapped to a separate lightmap chart than the side of the cover, so there is a lightmap seam between these two surfaces. The lighting on the top is much stronger than lighting on the side, so the lighting on both sides of the lightmap seam varies significantly. The lightmap post processing step which attempts to minimize the seam visibility is unable to do it effectively in such a case.

If you’d already raised Custom lightmap resolution for the cover to 200, and it wasn’t automatically lowered because of exceeding the Max lightmaps setting (you can check if it happened in the Objects tab), then unfortunately this seam cannot be improved.