Back to the Shapespark home page

How to increase shadow intensity

First of all, thanks again for your previous help! I have seldom seen that so professionally!
I am very impressed with the program. Everything works out very well.

But to appear more realistic, I need more shadows. The objects that touch the ground appear to be floating in the air. Please consider that the model is quite large. A supermarket area of 7000m2 with lots of products on the shelves. Has approx. 34 million polygons. Have tried various settings when “baking”.
However, nothing changes. Is there a switch somewhere or which setting do I have to change. It seems to work better on previously smaller models I’ve made. Is it the overall model size or maybe only the size 7000m2 of the floor area?
Would be great to get help …


Thanks!

What’s the lightmap resolution for the floor in this scene - you can inspect it in the Objects tab? If there is a property called Auto lightmap resolution for the floor it means that the lightmap resolution had to be scaled down, so that the whole scene could fit into the number of lightmaps given by the Max lightmaps setting of the Bake tab.

To give you idea how the lightmap resolution affects shadow precision: lightmap resolution = 20 means that light is sampled 20 times per one meter, which roughly corresponds to shadow precision of 100cm / 20 = 5cm.

If you haven’t done so yet, you can increase the Max lightmap setting. It will lead to increasing the lightmap resolution, but at the cost of increasing the baking time and the scene size.

BTW, 34M polygons is a lot. Are there any geometry optimization opportunities that you could apply to reduce the scene complexity? This would help to open the scene on weaker devices, including mobile phones.