Back to the Shapespark home page

How to two or more walkthrough if project is big?

how to optimise project if project is big.

and how we can attach two and more walkthroughs?

If the project is big in terms of the total area, you can reduce lightmap resolition either for the whole scene (the editor Bake tab, Lightmap resolution setting), or only for the largest objects in the scene such as terrain or walls (the Objects tab, Custom lightmap resolution setting).

If the geometry has too many triangles, you can identify the most complex objects in the Objects tab - the objects list in this tab is sorted by the number of triangles. Shapespark doesn’t include geometry optimization tools, so you need to optimize or replace too complex objects in your 3D modeling program.

Could you share a link (here or by email to to a scene that you need to optimize, so we could provide more specific hints?

One way to present multiple walkthroughs is to embed them together on a single web page, each walkthourh in a separate iframe (see the iframe HTML code here:

Did you ever think about an “in-game” solution? Like loading levels in a game? For example, if you have a larger area with houses it is not possible to use high baking settings because of the large area. But interior renderings need that high settings. So it would be nice to walk through that area, go to a house and enter the stairwell. If doing so a new “level” is loaded which contains the baking (or dynamic lighting :wink:) of that house.

please help

Are you asking for help with regards to the white artifacts in the ceiling? If so, then these are so called light leaks. A light leak occurs in places where one lightmap pixel stores light information for a surface square that is in part bright and in part dark (eg. one lightmap pixels covers both the surface over and under the ceiling).

It seems that the building in your scene is not axis-aligned, but rotated by 45 degrees around the up axis. The light leaking artifacts would be much smaller if you made the building axis-aligned (walls parallel to world axes). Could you try reorienting the building and baking the scene again?

As for the optimizations:

The geometry is quite small (~800.000 faces), so there is no need to optimize it further.

The building floor extends far outside of the building which increases lightmap size. It would be better to remove the parts of the floor that are outside, or to split the floor object into two: interior floor and terrain and set ‘Custom lightmap resolution’ for the terrain to 5 or some other low value.