Back to the Shapespark home page

Material Picker Error After Bundle

Hello all,

I am having a problem that I am noticing only after a bundle. Certain materials under my material picker only show up as either black, or what looks like a glitched image of a light map. Oddly, it only happens on certain materials, and certain objects (not necessarily every object that is that material).

I have tried re-baking, re-bundling, and checking for corruption in my jpg images. When I re-load the diffuse jpeg, the problem goes away, until I bundle for web again. Then the problem affects the local file as well.

Any ideas or help would be greatly appreciated.

1 Like


Please find a solution to this issue in this post: Textured problems

Let us know if it worked.

Hi Wojtek,

Thank you for the response. Unfortunately, none of the posts in that thread really address my issue. A few more notes:

  • I have a palette sitting in the scene for material picking.
  • Some objects change materials no problem, while others have visual glitches (for example, countertop in bathroom of scene changes just fine, but counter in kitchen (displayed in original post) has issues.
  • I have replaced problem geometries and problematic materials and am still having the same issues.

Any other ideas?

Thank you for your help!

** EDIT **
I have narrowed down when this happens – it is only after I use the Bundle tool. I noticed that it also affects my working file.

Hi Mike,

Is this scene uploaded, so we could take a look? You can send us the link via PM or if you prefer not to disclose it publicly.

The important thing about your material palette is that each palette item has to be larger than its texture tile. So, for example if a texture tile corresponds to 1 x 1 m in real world, the palette item should be larger than 1 x 1 m, eg.: 1.5 x 1.5 m, so that texture tiling is visible on the item.

What 3D modeling tool are you using? If you’re using SketchUp you can see the palette item-texture size relation in this part of our video tutorial:

I will email you the files.

I am using 3ds Max 2017 and the latest version of Shapespark.

Thank you.

we are having the same problem, and I think our tiles are big enough

Hi @kotekvirtual,

Could you share a link to the scene with us? And, if possible, also a screenshot of your material tiles?

We finally fixed this by resizing the texures and reapplying them from the modelling software, instead of changing textures directly from Shapespark, I hope this can help with other people having this same issue in the future.

1 Like

quote=“kotekvirtual, post:8, topic:961”]
modelling software

Hi @kotekvirtual I also got the same error in 3dsmax 2019.
I look forward to your help.(I have to turn on Emissive)

@Khang_Tri_u, could you share a link to the uploaded scene, so we could take a look at it? If the scene isn’t public please send the link to

1 Like

Thank you. I have found a way to solve that problem.
by command flip in 3dsmax.

1 Like