Reflections appear black on a specific device

I was having an issue where all the reflective elements like mirrors and metal are appearing black on this device while it runs and looks fine on other accounts/devices.
Usually this problem is solved by

  1. clearing browser cache
  2. trying incognito login or alternate account login
  3. switching from chrome to other browsers like firefox
    but none of these are the solution in this case

additionally, we have also tried updating the walk.min.js and other associated files on the host side and updating the scene thats built on a newer version of shapespark.

Desktop - Windows 10 Pro - 64bit
Processor - Intel(R) Xeon(R) CPU x3430 @ 2.40GHZ 2.39GHZ
RAM - 32 GB
DirectX runtime version - 11.0
Graphics - GeForce 9400 GT - 4095 MB
attached images of how the scenes are appearing

Any inputs regarding a possible solution would be helpful

Do you have access to this device? If so, could you open Chrome developer tools (F12), go to the ‘Console’ tab and check if there are any errors reported when the scene is loading?

If it happens only on this single device, a likely reason can be a graphics driver issue, perhaps there are newer drivers available?

hey jan,
Thanks for reaching out, these are the console errors:

  1. cube face has all pixels black
  2. Assertion failed: can’t set uv offset and scale if baseColor texture is in atlas
    Screenshot 2022-09-28 175614

Is this some old version of the library? The 2nd error is no longer be present in the newest version. Could you test also with Shapespark hosting? It always uses the newest version of the library.

Yes, This was the older version of the library but after updating to the newer version the 2nd error has been resolved. updating the drivers will take time since I don’t have access to the device. if that doesn’t fix the issue we will be sure to try Shapespark hosting as well
I’ll update this thread if that resolves the issue.