Back to the Shapespark home page

Artifacts in rendering

Good afternoon everyone, @jan and team, could you please tell me why these artifacts, even with a very high bake, and how to solve this problem?

This scene of ours is still under construction ok the exported materials came from 3ds max with Standard Material

Thanks



It looks like a lightmap resolution was reduced for the ground due to its size. You can confirm this in the Objects tab which shows the actual lightmap resolution used for each object.

The size of these dark shadow squares are likely one lighmap pixel. The pixel centers are below the curb so are baked dark, but the curb doesn’t cover the whole lightmap pixel, so the darkness is visible on the pavement.

To fix this try either:

  • Gradually increase the Flood dark limit (not too much) and run Post process again. Larger Flood dark limit should cause these pixels to be flooded. Do not increase the limit too much, because it will cause real shadows to be also flooded.
  • or enable Isolate shadow option for the curb in the Objects tab. This way the curb won’t be casting shadow on the pavement.
1 Like