Back to the Shapespark home page

Bake Failed: process exited with non-zero error status


#1

50% of my bakes are coming up with an error alert.

“Bake failed: process exited with non-zero status.”

I’ve tried my CPU and the graphics card with no change in outcome.

Is this a known issue? I really like this software and would love to use it if I can resolve this. Many thanks!!

bake failed|407x156


#2

Could you upload the failing scene and submit an error report from the application main window Help & Support tab with Attach Shapespark logs to the report. checked? We haven’t recently received other such reports, so the logs and the scene would be very helpful for reproducing the problem .


#3

We continued this discussion via email, but we are able to reproduce this problem and one more user reported such bake failures. We are working on a fix.


#4

Hello,

I did some tests on different graphics devices and the result was this:
recognition of the device:
Intel I7 CPU = yes
CPU AMD Octacore = yes
GPU nvidea GTX1080 = yes
AMD Radeon R9 380 GPU = no

how to lightmap configuration:
Intel CPU = 75 (ok)
CPU AMD = 65 or less = ok
GPU nvidea GTX 1080 = 75 = okkkk


#5

If you mean that the AMD Radeon is not listed as potential bake device, then this is as expected. Shapespark can bake only on CPU or CUDA-enabled GPUs (NVIDIA only). Baking with OpenCL-enabled cards, like Radeons, is not supported.

Do you mean that using lightmap resolution greater than 75 is too slow, or do you mean you’ve encountered some failure on an AMD CPU?


#6

Bake failed “non-zero erro”…Just 65 or lower


#7

This issue has been fixed in Shapespark 1.5.4 that has just been released.

(The new version should be automatically installed the next time you launch Shapespark.)


#8

Hi there,
got the same problem with a large szene. Quadro and Cuda cards used also as cpu - same error.
Any ideas? Thx!


#9

Hi!

Thanks for the report. Would it be possible for you to upload the scene to our hosting, so that we could try to reproduce and analyze the issuse?


#10

I can do - but it should not be in public. NDA things :slight_smile:


#11

Ok, so you can either:

  • upload it with using an obfuscated name and send us the name via email/PM or,
  • pack the contents of the scene folder in Documents\Shapespark and send the archive to us.

Thank you.


#12

https://woelkedesign.shapespark.com/beckman-coulter---future-lab/
I did it :slight_smile:


#13

Is there a button to say “Private” for example? Or with password?
Would be great for some projects :slight_smile:

Right now I’m just baking only the room - that works. I tried to figure out where the problem is by try and error :slight_smile:

I like to sell this 3d View to my customer asap and be a pro then :slight_smile:
Therefore: A version to configure rooms with equipment (as you can see at my example - would be also a good idea :-))


#14

There is currently no option to make a scene private/password-protected. What we suggest in such situations is name obfuscation, please see the bottom of the FAQ.

We’ve downloaded your scene for analysis, so you can remove it from the Shapespark cloud if you wish.


#15

I can confirm that we’ve reproduced the issue, and we will be looking into it.

The background for the issue seems to be very complex and irregular geometry of some of the objects in the scene. It seems Shapespark has difficulties to properly unwrap them to produce lightmap UV mapping.

Are some of the objects coming from a CAD application? Cleaning/optimizing such objects in the 3D modelling tool could work around this issue. Optimizing them may be helpful anyway, as many of them have high polygon count making the scene total to 7M polygons, which is too much for mobile devices or older computers.


#16

Ah, thx. Yes, the models were provided by customer and I know that there are some small problems. I will take a look at it. :slight_smile: