Back to the Shapespark home page

Bake is only using 1 GPU when both are selected

Hey team, I have an RTX2080 and RTX2070 Super. When both CUDA devices are checked, only the RTX2080 is being used, while the RTX2070 Super remains idle. If I only select the RTX2070 Super, then it works and hits 100% load, but then of course the 2080 is idle.

Is there something I’m doing wrong? Any thoughts on how I can fix this and get it to use both GPUs to bake?

edit- I solved it. Closing and restarting Shapespark didn’t fix it, but restarting the computer did. Guess I should have tried that first before posting. I’ll keep this up for others who might run into the issue. Still a bit odd, and not sure what could have caused it.

2 Likes

I’d like to followup with this. I’ve now had to restart several times before baking to get all of my video cards to show a GPU load when baking. It seems to be an issue with other software capturing the secondary GPUs and while Shapespark detects them, only a restart can get it to use them during bake. This other software might be Vray for Maya, or Maya itself, but could also be caused by Photoshop or PixPlant. I haven’t narrowed it down to one yet, but that seems to be what’s happening.

Hi!

May I have a few questions to help us with the investigation?

  1. What tool are you using to monitor the GPU load?
  2. Could you check if it’s not just an issue with GPU load monitoring? Is the bake time actually longer when monitoring shows 100% + 0% if you compare it to the “clean” 100% + 100% time?
  3. When monitoring shows 100% + 0%, what would happen if you selected just the second GPU (0%) for the baking?
  4. When you see 100% + 0%, could you check if all the GPU-related apps (V-Ray, Maya etc.) are closed? In particular, could you check the Task Manager if they don’t have some processes still running in the background?

That said, at this moment we don’t know yet if we can do anything to improve it on our end. Unfortunately, it might be an OS or drivers issue.

  1. I’m using GPU-Z
  2. Yes, it does take approx 2x longer when the second card isn’t activating
  3. When monitoring shows 100% + 0%, if I stop the bake and select the 2nd card only it then shows 0% + 100% when baking. This seems to only affect when both cards are selected to bake.
  4. I’ll have to test and confirm this next time I run into the issue. I do suspect that there’s another GPU related app that’s causing the issue. I’ve narrowed this down to Vray, Maya 2020 Viewport, or PixPlant. I’m not sure if closing the offending app closes the issue though–only a computer restart has solved it so far.

Thanks for the feedback.

One more thing you can check the next time you run into the issue is CUDA utilization reported by Windows Task Manager. If you go the the Performance Tab, and select a GPU, you should be able to change one of the real-time charts to show “Cuda” utilization (by clicking on the “3D” next to a dropdown arrow).

1 Like