Back to the Shapespark home page

Baking suddenly takes very long?

I used to be able to bake pretty quickly, but now even when I’m baking on draft with a single lightmap I see this in the progress bar:

“Baking lightmap 1 of 1, part 1 of 6198”.

The ‘part 1 of 6198’ note was never there before, and when the baking was done it’d just go straight to denoising. Now when the progress bar is ‘done’ it very slowly increments through all the ‘parts’, taking literally hours when previously a draft bake would be done in 10 minutes. What’s going on?

EDIT

I’ve noticed it only happens in my current project. This doesn’t happen when I create a new project using the same model (imported from Sketchup). It’s still quite a problem because I don’t want to lose all the changes I’ve made in the Shapespark project.

Baking parts of the lightmap separately means that you must be using the Isolate shadows option for some object in the scene, and this object consist of thousands of other objects.

If you need to keep the Isolate shadows option for the object, merge all the component meshes of the object into a small number of meshes, as this will reduce the number of the lightmap parts to bake.

2 Likes

I’ll take a look Wojtek. I don’t remember touching the ‘isolate shadows’ function, as far as I can remember the issues started after I re-imported my model from Sketchup.

EDIT

That was indeed the problem. I could swear that I’d baked several times since I enabled that function, but I must’ve remembed incorrectly. Thanks!