Black artifact issue in Shapespark scenes

Hello Shapespark Community,

I’ve been noticing black artifacts in my scenes for some time now. First, I would like to understand what causes them and learn which specific settings in Shapespark might eliminate them.

Additionally, I am seeking advice on key settings to enhance the rendering quality. Attached are screenshots from two scenes where these black artifacts are present.

Any advice to help me resolve this issue would be greatly appreciated.

Thank you very much!


Have you had a chance to try the solutions we discussed in the emails for your issues?
As for the plane scene, I did some testing and found that getting rid of extra spotlights and area lights worked well. Having too many lights can create issues in the lightmap, especially if the resolution isn’t high. I successfully baked the scene with a lightmap resolution of 150, and for exterior objects, I set it to around 30-50 (you can set it up in the Object tab).
This is a result I got:

and settings I’ve used:

Here you can also find some tips and answers to most common problems in baking:


Yes, I have made the changes we discussed over email. This has improved the scene, but I find it’s not yet perfectly clear, as I can still slightly perceive artifacts. Are you referring to the removal of the ceiling lights, as shown in the screenshot I sent you? I will try to make the changes you suggested. Was it a deliberate choice on your part to bake with a resolution of 800, or can I bake my scene with a higher quality, say 1200?

Placing outdoor objects with a lightmap value of 50 enhances the quality of sunlight on the airplane’s fuselage, doesn’t it?

yes I removed all spotlights from your plane scene and added only 2 or 3 point lights inside.
Outside object receive a lot of lights from the sun so they won’t need this high resolution, that’s why I recommended lowering resolution for them.
You can bake your scene with 1200 or even higher if you want. It should also improve the quality of a bake.


Are the lights you added more like spots, points, or areas? Can you show me how you arranged them? So, if I understand correctly, it’s not necessarily mandatory to add a light spot to all 3D objects that represent lights and are placed in the scenes?
Okay, I understand better now about the external resolution, thank you.
Is there a cooking limit?

this is how the lights look like in my scene:

Like I said before having too many lights can create artifacts in the lightmap. That’s why I left only emmisive material in the lights - so it’s looks like the light is coming from there, but it comes from few area lights (I left only half of those that you have created) 3 point lights and the sun.

All right
I’m going to take the test. Do you think that in this scene the problem is the same with the artifacts? Villa PALM by VIRTUAL AGENCY 3D

When I delete or add lights or modify the lightmap of objects do I have to bake the scene again?

Issues related to the scene we talked about in our email correspondence. Have you experimented with the suggestions I provided? Try baking it without Ambient Occlusion, and ensure that objects aren’t getting stuck in the walls. Additionally, increasing the lightmap resolution is advisable, but similar to the plane scene outside objects can have a significantly lower lightmap resolution.

Yes, after changing any baking settings or lights you have to bake the scene again.


Link of the new visit with new settings: Villa MAGESTY by VIRTUAL AGENCY 3D

I’ve made the changes you suggested for the scene. For objects stuck in the walls, I managed to remove the artifacts by increasing the lighting in the area itself (see the screenshot for example).
I rendered the scene with a lightmap of 200 and a luminous map of 1200. I am considering further increasing the value of the latter. By placing light points in certain areas, this has significantly reduced the artifacts. I also used a higher value luminous map for rendering the scene and am thinking of adding more light points in certain areas. Here is a screenshot of my baking settings. I’m wondering if I should increase the “flood dark limit” parameter.

I also experimented with the object switch function. To do this, I placed objects in the same location in my modeling software. I also isolated the shadows, but it seems that the objects below do not receive light. Therefore, when switching objects, the one underneath has dark areas. Is there a solution to solve this problem?

Have you enabled “isolate shadows” for all the objects you are using in the object switch extension?

For flood dark limit, 0.2 is the maximum. However, in most cases, we don’t advise using a value higher than 0.08 because it will cause the scene to lose dark shadows.

Have you tried using the AI denoiser with this scene? You can run only post-processing with this denoiser turned on and check if it improves your results.

I had the shadows isolated after baking the scene. Do you think I need to recook the scene?

I haven’t enabled the AI ​​denoiser, I’ll try it.

Yes, you need to rebake the scene.