Back to the Shapespark home page

Black shadows after hiding object

hello,

https://rotemco.shapespark.com/mp_2_skp_with_furniture_01/#view=Empty

why do I see black shadows although the objects are hidden?

@rottem try to make carpet transparent.

It is not a good solution because I want to see it in the “full” view

The problem is that light and shadows are baked into the scene. That means that the shadows your objects are casting are stored. If you hide them in one view the information of light and shadow are still there because it is the same scene. What you want to achieve would be possible with dynamic light which is not supported by Shapespark.

Ok, then try ambient occlusion and quit every light in the room. But the shadow from carpet is almost impossible to erase totally! You need to ‘hack’ the render process by experimenting with some settings.