Back to the Shapespark home page

Browser reloads (crashes) on older MacBook Pro

Hi, someone just pointed out that some of my Shapespark scenes don’t run on older MacBooks.
I was able to confirm the issue on a MacBook Pro (Retina, 13-inch, Late 2012)
It got a Dual Core i5 with Intel HD Graphics.
I have tried uploading a very basic scene with a low (70K) triangle count and it still crashes.
The problem occurs in both Safari and Chrome. The scene almost loads and then the browser crashes with the message “This webpage was reloaded because a problem occurred”.
Here is one of the scenes that I’m having the issues: 3D scene
However, almost all of them do not run on that MacBook.
I tried self-hosted scenes with the same results.
Any help much appreciated.

Hey

The issue seems like could be related to our update for WebGL2 support. Could you please check if you have enabled “experimental webgl2.0 support” in Safari Develop menu (Develop > Experimental features > WebGL2.0) ? However if you did not change your default settings please let me know, as Shapespark should work correctly with webgl2.0 disabled.

I would be grateful If you could provide me with safari and chrome version on which problem occurs.

Thanks for your quick reply!
I did a software update to the Catalina 10.15.7 and everything works now. Both, self-hosted, and Shapespark-hosted scenes are no longer crashing.
Unfortunately, I did not check the version before doing the update. The current Safari version is 15.5, Chrome 101.0.4951.64 It works now with or without the webgl2.0 support.
I’m guessing that it was possible some graphics driver issue.
Once again, really appreciate your support!

Thanks for the update! I’m glad the issue has been resolved.
No problem, we are here to help!

Best