Back to the Shapespark home page

Default Material Problem


#1

Since updating to version 1.5.6, I am now getting a series of crashes with the following message:
BakeFailed

I am trying to update all surfaces that are using the “default” material and finding many more than I would have imagined.

This was not a problem before updating to the new version today.

.


#2

We are not yet sure if this is related to the Default SketchUp material. Could you upload the current version of the scene, so that we tried to reproduce the problem? If you don’t want to overwrite your current scene in the cloud you can first make a copy with a different name in the Documents\Shapespark folder.


#3

Here is the copied one. Carwash with SU default material

I found a lot more default material than I expected in the model. I spent a lot of time yesterday trying to find and change them but there is still some left. You will see that the scene is not baked. I got the error message several times yesterday. Hope this can be resolved as I am sure others will have default materials as well.

EDIT: This file has been deleted…


#4

I created another model/scene that has nothing but SU default materials and did not have any problem. As I get some time, I will continue playing with this model to see if I can recreate the problems I seeing yesterday.

Here is the new model: SketchUp Default Materials Testing

EDIT I deleted the file.


#5

Thank you for investigation on your end. We have also done some tests and the issue does not seem to be related to the Default SketchUp material.

So far we have been unable to reproduce this bake failure on your scene. Does it happen each time you try to bake the scene? Both with the CPU and GPU/CUDA? Could you send us a problem report from the Help & Support tab of the main Shapespark window just after the failure? It would allow us to analyze the Shapespark log files.


#6

Just started the bake. Will let you know when it finishes/crashes.


#7

Just baked with CUDA and IT worked…
Tried with CPU and it worked too.

I will try some additional testing later today (if possible).


#8

I just went back to the SketchUp model and made some changes (not big ones), reloaded it into Shapespark and baked again. No problems were encountered.

As of right now, I am somewhat confused as to what caused my errors on Thursday. I will keep going at it a little at a time and see if any additional problems develop.

Would almost like for one to happen if it would uncover a problem that needs fixing. Until then though, thanks for the follow up.


#9

I just had another failure. It did not mention anything about the default materials. The failure message is just like the one in the first post in this thread. It failed on step 1 of 5. I did submit via the support link.

I had done a couple of successful baking’s yesterday and got kind of aggressive with the stuff I added to the model today.

Hope we can resolve what is going on and come up with a fix.


#10

Thanks for sending the problem report with the logs.

Since your scene has become larger, I think your last failure might have been caused by not enough free video RAM for baking on the GPU. Did you have some other 3D apps (eg. SketchUp) open when this failure happened? If so, could you close these apps and try to bake once again.

Also, could you check if baking works properly if you switch to CPU (to make the check shorter you can lower the number of samples to 1)?


#11

No, I did not have any other apps running. I wondered if that could have been the problem from before as well so I made sure nothing else was going on, on the computer (which is a laptop).

I will try with the other settings to see what happens.


#12

We have reproduced the problem and we are investigating it. The issue is with one of the post-processing steps that are performed on a baked lightmap.

As a workaround, until the issue is resolved, you may clean the Enable filters checkbox in the Bake tab. This will allow you to continue working and baking your scene, albeit the result will be a bit noisy.


#13

Yes, that let me bake it but the result was pretty bad. I have enabled it but set it at .025 and will see what happens.


#14

I think you don’t have to test: it will fail. The issue is independent of the flood dark limit value.


#15

Yes, you are correct. It failed even with the adjustment. So, I cannot bake and get a result that is acceptable.


#16

We have found the issue and fixed it. The fix will be included in the next release.


#17

Any timeframe for that? :blush:


#18

We plan to release the new version by the end of the month.