Back to the Shapespark home page

Exterior light probe reflection

Hi, currently I’m working on a exterior project, and I was wondering why the light probe sphere is cannot reflect the objects that I want. It will keep reflecting wrong reflection. How should I resolve this problem ?

The reflections based on light probes are only an approximation of physically correct reflections. For exterior scenes, when light probes don’t have bounding boxes the accuracy is usually lower than for interior scenes.

Are you using one or more light probes? In Shapespark a single mesh can use only one light probe. So, for example, if you’d like to use distinct light probes for walls on different sides of the building, you’d need to split the walls into separate meshes.

I’m using more light probes because of the exterior floor I have few materials , so mean that I need to split the each material floor into separate meshes/group to reflect the correct reflections ?

Below is the example

Yes, however it may cause visible seams on edges which separate a mesh with one light probe from a mesh with another light probe.

Are you using bounding boxes for the external light probes? Have you tried turning the bounding boxes off to check if it reduces the reflection artifacts?

Yes I put the few light probe for the exterior but I already separated the floor meshes. I have tried to turning off the bounding box but the reflection will not accurate on my floor. Any solution or exterior is not necessary to put light probe ball ?

Could you share a link to the scene with us for analysis (for example via PM)? I am afraid that achieving reflections close to accurate might be difficult for the exterior of such a building, but perhaps there is some light probe configuration that would improve the current result.

Sorry because this is the private projects. For what I understand for light probe ball is that only require for interior (interior should be no problem) but when come to exterior of such a building project then will have this kind of reflection accuracy problem.

Another problem is that shadow problem. My sun setting is
Strength : 10
Size : 0.01 (already minimum of the size)

Sky strength :0.4

But after texture bake outcome I can’t see any shadow on the floor.
Sun direction base on this photo is from left bottom to top right. So on the floor should have my table set and booths shadow.

Another questions are confused me too. Why I’m using preview in progress my projects shadow is can show it clearly but when I’m texture bake my scene that no any shadow on the floor ?

You can compare the below image and my previous reply message attached images. Thanks

@wojtek Hi, do your side have any solutions on my issues ? Thanks

Yes, the accuracy issues with light probe reflections are larger for exteriors than for interiors: one light probe might be not enough for a terrain around the building and multiple light probes might generate visible seams.

It looks like the lightmap resolution of the terrain is very low. Could you check what Lightmap resolution and Auto lightmap resolution (if present) does the Objects tab report for this object?

okay noted. Mean that is not necessary to put light probe for exterior ? If that case how the exterior generate reflection ?

For an examples: currently my lightmap resolution setting of texture bake is 100 . I checked for the floor object lightmap resolution is global(100) and Auto lightmap resolution(present) is 4 . Should I turn on Custom lightmap resolution and increase to 100 ?

Ann should I just need to turn on the Custom Lightmap Resolution for the floor object only or also other surrounding objects that can cast shadow ?

Just for the floor object. However, if the auto lightmap resolution for this object is 4 it means that the lightmap resolution for this object had to be aggressively reduced so that the object could fit in a 4096x4096 lightmap = the object must be very large. Perhaps you can split this floor object into two parts - one part near the building, where you need more detailed shadows, using higher custom lightmap resolution (20 should be enough), and the second part further from the building using lightmap resolution = 1?

BTW, if your scene has large area, you can raise the limit for the number of lightmaps: Max lightmap in the Bake tab.

Okay noted, since my floor objects is quite big and I’ll try to separate to 3-4parts to get the best shadows. Because this is the commercial projects so can I put the lightmap resolution to all the floor object 20 ?

How is the maximum limit for the number of lightmaps: Max lightmap in the Bake tab ? Currently default is 2

Yes. However, if there is a large part for which there are no shadows or the shadows are not important you can use much lower resolution for it to leave more space in the lightmaps for the other parts.

2 means that the whole baked lighting information has to fit inside two 4096x4096 lightmaps (technically, lightmaps are textures). For a large scene you can increase it, but it will make the baking time longer, the scene load time longer, and the viewer memory consumption higher.

okay sure. I’ll try to manage on my side.

1 Like