Back to the Shapespark home page

First Model - Have some questions


#1

Here is a link to my first model: https://ntxdave.shapespark.com/carwash/

Yes, the model has some problems but it is an old model that I was using for testing Shapespark (I currently just have the trial). Through another thread, I have already learned how to fix problems with some missing faces (I need to go back and fix some things in my SketchUp model - I used some stuff from he 3D Warehouse) but now I have some questions for moving forward:

  1. Is there a way to change the model/scene name (both before I upload it and after uploading it)?

  2. When you look at the first view, it is way too light. I to the Lights and then selected Sun (which is the first light on the list) and tried to reduce the Strength to 1. I then went to Bake and clicked on Preview but do not see any change. How do I get this changed?

  3. I have added a Point Light to the Support Equipment room and when I preview it, it looks fine. However, when I go to the Top view, the room is still dark and I cannot figure out how to correct that dark room.

  4. Is there any way to add a background (i.e. HDR)?

  5. When I render/Bake the scene, I have the Samples set to 200 and it took about 8 hours to finish the 4 cycles of the baking process. Is this normal?

  6. When I bake, should I use CPU or CUDA (CPU: Intel Core i7-4700HQ CPS @ 2.40GHz and the CUDA: GeForce GTX 765M (Display))?

OK - These are my questions for now. I am sure there will be more in the future (before my trial expires). :grin:


Material Problem
#2

Hi, your scene looks very promising. I’ll try to answer your questions one-by-one.

Locally, on your computer all the scenes are located in C:\Users\YOUR-USER\Documents\Shapespark. To change the name of the scene, simply change its directory name and reload the scene list in Shapespark (Ctrl+R). Only URL-friendly characters are allowed in scene names: lowercase Latin letters, digits, _ (underscore) and - (dash).

The name of a scene on the hosting cannot be changed, so you have to change the name locally and then upload the scene once again (under the new name).

Lighting is computed only when the scene is baked, so any changes in the light setup require a re-bake. When setting up lights, it’s best to use the Preview button to see how the scene will look like after baking.

I guess the answer here is the same as the above one.

You can add a background in the Sky tab. This background will be used only for presentation, it will not used as a light source during baking.

Yes, using the CPU or GPU that you’ve mentioned it seems normal. The baking time is proportional to the total surface area of the scene (lighting has to be computed for each surface spot of the scene), which is quite large in your case.

To cut down the baking time you can decrease the lightmap resolution in the Bake tab. The relationship between the resolution and baking time is roughly quadratic, so if you decrease the resolution twice, the baking time should be roughly 4 times shorter.

An important method for optimizing the baking time, and also the scene size, is setting custom lightmap resolution for some specific parts of the scene. This is configured in the Objects tab.

In the case of your scene you could try the following:

  • Use the main lightmap resolution of 60 (set in the Bake tab).
  • Use custom lightmap resolution of 10 for all the large objects with very uniform lighting, eg: the external faces of the walls, the external faces of the ceiling and the external faces of the floor.

Looking at some benchmarks it’s difficult too say, as it seems they could be on par. So probably it’s best to try both on the same scene.

Other than these, the most important thing that comes to my mind about your scene is the opacity of the windowpanes. Now, the opacity seems a bit too high - it blocks much of the sun & sky light. You could try using the opacity of 0.05 both for the external and internal windows - the rooms should become brighter.


#3

Thanks a ton for your reply. I will go through each of the points and try to get some things corrected. In a cope of places I will have to go back to SketchUp which, I think means I have to start all over. Wish there was a way I could go back and make some modifications in SketchUp and then bring my changes into Shapespark.

Again, I really appreciate your answers…sure I will have some more before I am done…:grinning:


#4

Actually, you do not have to start all over. When you try to export this model from SketchUp to Shapespark for the next time you will notice that the export type is Update an existing scene instead of Create a new scene which means that your SketchUp changes will be synced with the existing scene in Shapespark. Just make sure, you use the same name of the scene for the export.


#5

OK - that is great news.

BTW: I just edited the original post with a modified scene name. I then deleted the original scene and uploaded with the new name. All I had to do then was modify the scene name in the post and “we are good to go”. With this last one, I can now go back to SketchUp do some clean up of the things you pointed out before (bad 3D Warehouse models) and get this all moving in a better direction.


#6

Well, I am going backward. This latest upload has everything very dark. I also have not figured out the correct settings to hide the roof on the Top view only…


#7

As for the roof, I think the problem is that your roof has only external faces, and no internal faces. In other words, there is a roof, but there is no ceiling. Could it be the case?

Having a well-lit exteriors and interiors in one scene is usually difficult. The lighting outside the building is many times stronger than inside, so if the inside looks good, the outside looks too bright, and it the outside looks good, the inside is too dark.

The easiest way for your scene could be using Ambient occlusion set in the Bake tab, perhaps using factor from the 0.05-0.1 range.

Other than this, I think you could increase the sun & sky strength a bit and your exteriors will still look ok, Also, make sure you’ve lowered the opacity of windows’ glass to 0.05.


#8

[quote=“wojtek, post:7, topic:62, full:true”] As for the roof, I think the problem is that your roof has only external faces, and no internal faces. In other words, there is a roof, but there is no ceiling. Could it be the case?
[/quote]

Duh! That is exactly what the problem was…

I used all of the setting you suggested except the sun & sky strength.

Still a little dark on the interiors and because I have back peddled the samples, the metal has lost some of its luster. I will keep trying though. I am getting a lot closer.

Again, I appreciate the response and any further suggestions are greatly appreciated.


#9

Much better :grinning:


#10

You can also adjust the brightness of the scenes without re-baking using the Exposure and Gamma settings in the Camera tab. These are global setting, so if you make the exterior darker, the interior will also become darker.


#11

Thanks for that tip - did not take much of an adjustment. I will remember this one for sure. If you look at the model again, I think it looks even better. JMHO :grinning: