Back to the Shapespark home page

Flood dark limit is not changed from 0.2 to above

For my scene, I tried to remove some dark areas by increasing flood dark limit.

It does not move from 0.2 to the above. Even if i put, for example, 0.4, it automatically changes back to 0.2.

(I also baked it with 1200 samples (super), and increased lightmap as well)

Please help me with this, as the product is the main selling product for my client, I really need to solve this problem.

My preview image from Shapespark is pretty clear as below.

So my questions are as below.

  1. is ‘0.2’ the maximum flood dark limit?
  2. What is the maximum sample size for baking? (I baked with Super option - 1,200 samples)
  3. Are there any other solutions for solving this problem?
  1. Yes, 0.2 is the maximum. However, in most cases we don’t advise to use a value higher than 0.08, because it will make the scene lose dark shadows.
  2. 1200 is a very high number of samples. It should be enough for your scene.
  3. The artifacts you’re seeing are caused by limited lightmap resolution. The default lightmap resolution = 75 means that light is samples 75 times per meter, so one lightmap pixel overs roughly a 1.3cm x 1.3cm square. Set Custom lightmap resolution in the Objects tab to a higher value for this object to improve the lighting precision for this object.

Thank you for the answers.

I already baked it with the custom lightmap of 130.

Should I increase it to solve the problem?

Could you share a link to the scene, so that we could take a closer look?

Yes, its https://3d.cobenef.com/ianes_showroom/

As you can see in my scene, 2 products are having similar problem.

I can deal with the rest. But these 2 models…I can’t find out the reasons and its solutions.


The Max lightmaps setting in the Bake tab limits the number of lightmaps in your scene to 2. This is too few for your scene to obtain the desired Lightmap resolution set to 130 in the Bake tab, so Shapespark automatically reduced the lightmap resolution for all the objects in the scene. You can check the reduced lightmap resolution in the Objects tab as on the below screenshot:

Try reducing the global lightmap resolution (Bake tab) to 75, it will leave more space in the lightmap for the objects you want the custom resolution of 130 for.