Back to the Shapespark home page

Google Cardboard accelerometers Problem

Hi Everyone, I have a walkthrough scene that I am trying in VR on google cardboard. My scene gets loaded on the Google Cardboard and shows in VR, but when I move my head, it’s stuck in one place. On phone its showing the two lenses after clicking on VR button. But It’s not tracking any of my head movements(rotation). I had tried on iPhone 10 and android phone too. Is there anything which I need to change to make it work?

Here is the scene which I had tried:
https://www.qubic.media/kunden/commerzreal/dwtg/dwtg_erdgeschoss/

@Mahesh, do you mean that positional tracking doesn’t work, but orientation (rotation) tracking works? Or both kinds of tracking don’t work, and you have to stare at one point in the VR mode?

Positonal tracking not working is not a bug - it’s not supported by WebVR on Cardboard devices.

I meant the rotation tracking is not working. when i rotate my head with my google cardboard mounted, its not updating the screen with my head rotation (just stuck at one place/view).

What Chrome version are you using on Android? Have you tried the native WebVR support: Vr Eye Distance ?

iOS blocks website access to device motion and orientation sensors by default. Starting from iOS 13 a website has to ask for user’s permission to gain such access. Permission request is already implemented for scenes on our hosting (could you try opening some of your scenes from there?) For self-hosting it will be available in the next Shapespark release.