Back to the Shapespark home page

Help needed with quality of mesh

Hi there,

I’ve recently been using shapespark demo to create an art gallery virtual exhibition experience.

However I’m not finding it easy to make the artworks in this exhibition look how they’re meant to.

Check out this example:

when previewed the mesh looks normal, but after baking I notice sharp edges on the mesh and I would love some help to prevent this.

Many thanks!

I’m not sure if the hard edges are due to limited default vertex accuracy in Shapespark (0.0005 meters) or is it a lightmap related problem.

Try changing the vertexAccuracy configuration option to some low value as described in this post.

If this doesn’t help, try increasing lightmap resolution for this artwork in the Objects tab using the Custom lightmap resolution option.

Hey Jan,

Thanks for reaching out.

I have no coding experience whatsoever but managed to change the vertexAccuracy config like you suggested and it looks much much better now.

Thank you kindly :slight_smile: