Back to the Shapespark home page

Help to improve shadow artefacts

Hi guys!

I’m having some difficulty avoiding shadow artefacts in the intersections between wall and ceilings/floors in my scene.

I know the reason why this effect is so visible in my case is that the lightmap resolution is automatically crunched in order to fit this very large scene into fewer lightmaps. I’m assuming that increasing the amount of lightmaps would make this issue less visible. But I’m wondering why this shadow is present in the first place. Is it because I’m using ambient occlusion for indoor lighting (the only other light source is outside sun)?

It seems like the outside roof of the building is casting a shadow which is visible through the indoor ceiling. In the image below the camera is in between the outer roof and indoor ceiling to illustrate the issue.

Any help greatly appreciated :sweat_smile:

The issue is not related to ambient occlusion. Pixels of the lightmap at the edge of the ceiling are partially inside the dark area below the roof, this causes them to be baked darker and, due to limited lightmap resolution, this darkness becomes visible in the room.

You could try the following improvement:

  • In the Objects tab use the Custom lightmap resolution setting to decrease the lightmap resolution of terrain and other large exterior objects, this way interior walls will use more lightmap space and will have better resolution (smaller lightmap pixels).

or with more work:

  • Model your walls in such a way that the top part between the roof and the ceiling is a separate object from the bottom part (so the bottom part is fully inside the room). This way only the top part will be dark, but this darkness will not be visible in the room. Each object occupies a separate space in the lightmap, so darkness from one object will not leak to another object.

Thanks so much for your response @jan, it all makes more sense to me now :slight_smile:

Since I’m not the one working on the 3D-model I will experiment with you first suggestion.

The scene I’m working on is probably at least twice the recommended size (both in poly-count and area) for shapespark projects. It’s hard to find the balance between being able to run such a large scene on mobile browsers and at the same time avoiding artefacts resulting from reduced lightmap resolution.

Ideally our 3D-model should only contain super-optimized low-poly assets, but unfortunately the people working on the model don’t have the time/resources to optimize the current resources they are using in Revit