How to have higher quality walkthrough

I noticed that my scenes lack realistic textures and attributes such as lighting. However, when I select the “bake button” to render, everything appears as it should. I have tried to increase the quality to the maximum level before publishing each walkthrough, but it doesn’t seem to make a significant difference. I was wondering if there is any way to improve the visual quality of the 3D virtual walkthroughs so that they look more realistic, similar to the renderings.

When you bring your model into Shapespark for the first time, it won’t have shadows or lighting -like in the screenshot you provided. To make your scene look realistic, you need to set up lighting and bake your scene.
Here you can watch an introduction video about working with Shapespark:

here is also a guide that you can get familiar with:

For more details on settings, especially in the Bake tab, take a look at these links: