Back to the Shapespark home page

Identify problematic textures?


#1

Hello… Long time.
does anyone knows how to identify problematic textures… you see… i had once again the same error of “FAILED TO GENERATE WEB TEXTURES” … last time i had to send my file to “help and support” and shapespark developers eventually help me to solve this… but it happend to me once more… ever since… i’ve have been extra carefull with my models i mean the ones that i download from 3d warehouse… by using plug ins like “CLEAN UP” naming all textures of the model… fixing reverse faces… and sooo… and still it happend once more… maybe i will end up sending my file once more to " HELP AND SUPPORT" even when i think it wpould be nice to have a tool that allows users to identify problematic textures??? or maybe theres already a way to solve this with out sending files and whatever… anyone??
anyway THANKS A LOT GUYS


#2

Hi!

From what you describe it seems the problem is the same as the last time: when Shapespark extension requests SketchUp to extract a texture from the .skp model and save the texture to a file, so that it could be imported to Shapespark, the saved texture file is for some reason corrupted.

The information about which texture is problematic can be read from the Shapespark application log files, which reside in C:\Users\<YOUR-USER>\AppData\Local\Shapespark\log.

Could you submit a problem report from the “Help & Support” tab. We will take a look at the logs attached to the report, and point you to the particular log entry which refers to the corrupted texture.

Could you also send us the .skp file, so we could try reproducing the error. The last time we were unable to reproduce it, so it seems the error may be related to your particular version or installation of SketchUp… What version of SketchUp does the Help > About menu shows?


#3

Thank you for sending the SketchUp file.

The issue looks as if it could be the same one as the last time. We cannot reproduce it in SketchUp 2018, so one of the possible reasons is that you are using some older SketchUp version, which contains some bug related to extracting textures from a model. What version of SketchUp are you on?

Could you send a problem report from the “Help & support” tab? It would help us to confirm it is indeed the same issue.

We will introduce a workaround in Shapespark for corrupted textures. If some of the texture imported as a part of a 3D model is corrupted, the texture will be imported as pure red. It will allow to successfully finish the import despite the texture issue, and then to spot the problematic texture in the Shapespark editor.


#4

@Antonio_Perez,

We have released a new version (1.7.0), which shouldn’t fail if some input texture is corrupted. The SketchUp export should finish succesfully in such a case, and the material with the corrupted texture will be assigned solid red texture.

Could you check if it helps for your model?


#5

oh nice thank you very much
Ill give it a try and let you know.
:hugs::smile::smile:


#6

The applycation got updated to version 1.7.2, and i tried to export my scene and it didnt worked :C


what could i do?


#7

So, it seems this could be a different issue than the last time, and which added a workaround for in the 1.7.0 release.

Could you send the application log files from the “Help & Support” tab? We’ll analyze the logs, and hopefully find a quick workaround for you, and a long-term solution to be included in the next release.