Back to the Shapespark home page

Laggy Camera Movements

Hi,

Recently in one of our scenes, we experienced a very laggy and slow movement of camera when we look up at the sky.

Scene Link : https://tour.virtualhomes.in/uk_iridium/

The tour has only 1.4 M triangles, which I think is well within the range of Shapespark’s smooth experience.

Can anyone suggest how do I make it smooth and lag free ?

Thank you.

To reduce the number of draw calls and improve performance Shapespark merges objects with the same material. This merging is not performed for transparent objects, because transparent objects need to be rendered separately to avoid artifacts. Because this scene has large number of transparent windows, it still has 15000 objects after merging phase, which can’t rendered smoothly. To fix this, you could either use fully opaque windows material, remove windows completely, or merge all the windows in your 3D modeling program into a single object.

Thanks for the info !

I tried to reduce the Opacity level to “0” to make the windows fully transparent. However, this did not solve the issue. I cannot remove the windows completely as it will not give a proper feel to the model. Can you tell me what exactly should I do to merge all windows as a single object ? I use Sketchup and have grouped all windows under one group. But that has not solved the issue. Am I missing something here ?

The first option is to make the windows fully opaque, not fully transparent, so to change opacity to 1. Then, you could make the material reflective.

The second option is to merge all the windows, or at least window glass panes, into a single non-hierarchical object. If each window is a SketchUp group (component) now, then grouping these groups is not sufficient. You would have to first use the “Explode” action of the right-click context menu to explode window groups and then group all the exploded faces into a single group.