Light blotches across multiple scenes since the recent update


Since the recent software update, my scenes are experiencing a disco ball effect across all areas after bake.

This is a scene which i have been working on for some months, and the problem is new as of the last few days. In order to rule out an issue caused by the source model, I baked one of my other scenes (different source model, smaller scale project) and the issue occured here also.

Please help,

1 Like


We managed to achieve good lighting quality in this scene with the following configuration:

  • high number of samples (at least 400)
  • enabled denosing
  • increased number of lightmaps (at least 5)
  • try increasing ‘flood dark limit’ parameter up to 0.05, this should decrease light bleeding

You can also set custom lightmap resolution for objects which are outside and for glass. Most of them are very strongly lit and they don’t require such high resolution.

This scene contains a LOT of objects and triangles and is really pushing the technical limits of Shapespark. It would work much better if you removed invisible objects and decreased the number of triangles.
Maybe you could divide this scene in two, for example by exporting one floor to one scene and another one to a different scene?

1 Like


After a lengthier investigation we have come to the following conclusions:

  • there are two main issues in your scene that make the lighting look undesirable:
    a) These blotches on certain surfaces, random places of higher lightness or other weird reflections on surfaces that shouldn’t be there.
    b) Light leaking through the walls, for instance in some places strong white light will come out of the wall or at other places red buttons in the wall will seemingly glow and shade the area around them.
  • these two issues are due to a) too low resolution of the lightmap for certain surfaces and too low sample count (noise) and b) Ambient Lighting combined with walls extending over the crossing with other ceilings.

To mitigate these issues you should first and foremost:

  • reduce the area that is being baked, by selecting objects that aren’t visible in the scene, but still take lightmap space and baking time. For instance, there is a lot of sun panels on the roof and their group of objects could have the setting Custom Lightmap Resolution set to 0. Ideally, you should get rid of all of the geometry that isn’t really seen or important in such a big scene as yours. The scene is very big and it’s really pushing Shapespark to its limits. A lot of objects aren’t visible or accessible in the viewer, so you should consider getting rid of the objects on the attic for instance.
  • remove all the lights (aside from sky light and sun light) as well as the emissive property for all materials that have it enabled.
  • set the custom lightmap resolution for glass (windows etc.) to 0.


  • make sure that the denoising is enabled.
  • use higher number of samples for the final bake (at least 400, preferably around 800).
  • use higher number of maximum number of lightmaps (at least 5, preferably around 8).

And eventually you could try one of these:

  • enable Ambient Occlusion alongside Ambient Lighting, this should fix the undesirable light leaking and other artifacts that can be seen in the scene.
  • disable Ambient Lighting and illuminate the scene using point lights around the scene, go around in the editor and use the preview to see if the current view is illuminated well enough, if not then add a point light near a lamp object.

The first one requires (Ambient Occlusion & Ambient Lighting) requires less work and we have checked that it should generate good enough results for your scene.
The second one (Ambient Lighting off and manual lighting of the scene) could theoretically yield better results, but may require more effort and a lot of playing around.

After these steps you could experiment with various settings for Dark Flood Limit, check which values work the best between 0.02 and 0.08 (you do not need to rebake for this, you can just run preprocess to see how it changes the way the scene looks).

I hope this helps.



Thank you very much to the team at Shapespark Community Forum,

Your efforts to provide a comprehensive list of advice has resolved my issue - very much appreciated.

The scale of our building is indeed large, and before embarking on this walkthrough project, we knew that the model size held the potential to undermine the rendering process, and were prepared for malfunctions. However your tips to enable the Denoiser, along with the Ambient Occlusion + Ambient Lighting has indeed solved the ‘disco ball’ and light leaks, which is great.

We have tried a couple of times to increase the number of lightmaps to 5 and above, unfortunately this appears to ‘break’ the bake (perhaps our graphics card or CPU cannot withstand it?) The result is a fully dark / black render, or black walls & ceilings, where they would be white. However…
this is not a cause for concern for us, in the meantime, the advice offered has generated a good quality render walkthrough, we are very happy with it, and I will further explore the other tips which have been kindly offered.

Thank you.

1 Like