Back to the Shapespark home page

Light Blotches in scene


#1

Hi, I have been using Shapespark for a while but am having trouble solving this problem. The scene I’ve created has little natural light so am relying on artificial light to illuminate the scene. I have added some material emitters to represent the light fittings and point lights in the areas. However I cam getting this blotching effect throughout my model. Any idea how to solve it ?

Thanks


#2

Such dark blotches may appear in cases where a lightmap pixel covers both a part of a surface that is visible and a part that is occluded. In this case one dark lightmap pixel covers both part of the wall that is visible and part of the wall occluded by the door frame.

Shapespark has a post-processing step to remove such dark lightmap pixels by flooding them from neighboring ones. This post-procesing step is controlled with the Floor dark limit setting of the Bake tab. The setting defines which pixels should be considered dark. Try increasing this value to 0.05 and press the Post-process button. If there are still dark blotches try increasing it a bit more.

By the way, the dark blotches are quite big in your scene. What lightmap resolution did you use to bake it?


#3

That has worked perfectly!

Yes it was a lower res bake, I’ve ran a higher one since then and the changed the bake limit and all the patches have been resolved.

Thank you