Missing shadow in the final rendering but looks fine in the preview

Hello expert!

We had a issue of missing shadow in the final rendering, however it looks totally fine in the preview mode.
Do you know what is the reason behind it?


Are you using the Isolate shadows for the furniture objects? If not, what’s the effective lightmap resolution for the floor object, as given in the Objects tab?

No, we did not use Isolate shadows for the furniture, otherwise, you won’t see shadow in the preview, right?

For the lightmap resolution setting, please see below:

The auto lightmap resolution of the floor = 1, so is lower than the requested lightmap resolution for the scene = 75. The floor object must be very large, and Shapespark needed to reduce the ligthmap resolution for it, so that it fits into a 4096x4096 lightmap.

Lightmap resolution = 1 means that baking samples the light each 1m of the floor surface, so one lightmap pixel covers an area of 1x1m. Such a resolution is way to low to store shadow details seen in the render preview.

How large is your building? Would it work if the interior floor object was separate from the terrain object?