Back to the Shapespark home page

No sky texture visible

Hi.

This is a project I am working on.
Exterior View Facade

I actually added a background image as texture but as you can see it is not visible. Any idea whats wrong? I used the same in another project without any problems. (Before the last update)

I think you could add a “Help” or “Troubleshooting” category to list this kind of topics.

Hi Tim,

Very nice building!

The sky texture in intentionally hidden in Orbit and Top views, it is visible only in the Walk views.

In scenes that we’ve tested, the sky textures did not look good if you were able to see large part of the sky sphere at once (which is the case in Orbit and Top views that show the whole model from the distance). The fake 2D nature of the texture becomes very apparent and the model looks like it is floating in the texture bubble.

You can see how your model will look with the sky texture, by temporarily adding a ‘Walk’ type view. Does it look reasonably well from the distance?

Perhaps we should revisit the decision to always automatically hide the texture in Orbit and Top views, and expose a Checkbox to control this?

Hi Jan,

thank you for this helpful tip. I already was thinking about buying a new graphics card. :wink:
I still have the problem with the LUT.

I think you should give the user the chance to make the decision on its own. It is always good to have the chance to decide from case to case. In this case, I want to use a texture with sky only. This is not realistic but looks not too bad from the top views. And from the eye level or a bit higher, it is no problem.

We think the LUT problem may be somehow related to your particular graphics card, but the graphics card itself shouldn’t be a problem. It’s rather something in Shapespark or drivers, but we’re not sure yet.

Anyway, you could always have a second graphics card, and bake the lighting faster.:wink:

:face_with_raised_eyebrow:

As for the sky texture visibility, we’ll add a per-view checkbox to enable/disable the sky texture for the view.

Great! Thank you.

My client needs the final model in about 10 days. You think you can implement it in an update until then?

Yes, we will do it by then.

Thank you! :crazy_face:

@tim, an update with this feature will be released on Friday.

Great! Thank you.
Is there anything else we can look forward to? :slightly_smiling_face:

This one will be a minor update - the per-view sky checkbox will be the main part of it.

Shapespark 1.5.3 with this feature is live. See the details here.

Looks good. Thank you for your fast support!

1 Like

Hi,
I wanted to use sky texture for reflection (light probes), but I do not want sky texture visible in any view. The problem is that if there is no sky, reflective materials appear lightened because of the huge white reflection surface surrounding the object (it should be seen in orbit view).
While trying to overcome the issue, I noticed unusual results considering baking and sky map.
If all my views are orbit type, the sky is not rendered in light probes, even if I turn on sky texture. If I make walk view with sky textured checked, the sky is not rendered in reflections. Only if I make one walk view with sky, the reflections bake fine. How can I overcome this problem since I do not want to have sky visible in any view, and I only want to use orbit views?
I also tried to bake with ‘fake’ view that I do not need, and delete unnecessary view after baking. This works fine while I am in edit mode, but when I bundle or upload the project, the reflections are baked again, and sky is not included in baking.

The light probes are generated in the first walk view. Orbit and top views are used only if there are no walk views. This is because orbit and top views often hide ceiling, which causes the light probes to be incorrect.

Light probes are not baked, but generated every time the scene is loaded, this is why your solution to add a temporary ‘fake’ view did not work.

The editor does not allow to achieve what you need, you would need to manually modify the scene.json file which is a bit involved process. Here is how to do it:

  • Add a fake view of type walk with the sky, ensure it is the first view on the view list and save the scene.
  • Open Documents\Shapespark\SCENE-NAME\ scene.json file in some editor (for example Notepad++ as described here).
  • Search for the name of your fake view in this file. You will see it has the following property "hideFromMenu": false, change false to true, save the file and reload the scene.