Phone VR headset and controler

Is there way to use controler in VR mode to move smoothly on scene. Controler works grat in fullscreen view, but when i change to VR mode its only activate teleport. (my bluetooth controler have 3 modes: mouse, joystick and vr and in all mode in vr scene view it use teleport)

Right, in VR all controller buttons activate the teleport.

The reason is that in VR walking with controllers is more disorienting than teleportation. The mind can be confused by the lack of acceleration forces and is more likely to react with motion sickness.

I thought that’s the reason, but some games for vr ex. on PlayStation use walking around in vr mode. Maybe simple warning or sugestion tu sit down before turning walking mode will be sufficient? Is there any way to turn this on for experimental porpses in shapespark editor?

OK, we have added support for #nogamepadteleport hash so you can test scenes with gamepad teleport disabled. Just append the hash to the uploaded scene url like: