Please tell me about the WEB GL error.

We have issue with viewing a scene as attached.
This happens only I view with particular Surface Pro device.
Do you have any advise?

Hi @kt_yasu1472

Could you check if WebGL is enabled?

  1. Click (Settings and more) > Settings > System and ensure that Use hardware acceleration when available is turned on.
  2. Open a new tab in edge and paste or type edge://flags/#enable-webgl2-compute-context into the address bar. Ensure that Enabled is selected for the flag called WebGL 2.0 Compute.
  3. Restart the browser, then visit to test.

thank you.
I tried it, but the error still appears.
In the first place, is it possible that the surface specs are too low to read?
This error occurs especially in Google chrome.
Please check it.


Does this error appears also on this example scene?

Are you able to run other webgl websites such as:!/

What do you mean by “this error occurs especially in Google chrome”?
Can you open the scene in another browser?

Best regards

Thank you very much for your valuable opinion Arima.

You can see 3 URLs.
I get an error when looking at the shapespark url.

A device that often causes errors is Surfacepro9.概要tab

Is it possible that the graphics driver or RAM is weak and errors are likely to occur?

Please confirm.
I am very troubled.

I hope I can provide additional information.

An error occurs when viewing this URL.

The error is a shader error as shown in the attached photo.

What is causing this problem?

please confirm.


We have manage to reproduce the error on integrated graphic card (Intel UHD Graphics)

The problem might be related to the scene size (too big scene or too many materials are causing to crash the viewer during loading data into gpu memory)

We do not know what is the reason yet, but we are actively trying to debug this issue, we will let you know as soon as possible about our findings.

Best regards

Thank you for confirming.

Errors occur even when the amount of data is small.

URL: 3D scene

please confirm.


We have narrowed the issue down to problem with gpu memory management either in chromium (chrome, edge) on Windows when using integrated graphic card or with intel driver itself. We have been able to reproduce browser crashing using other WebGL engine.

We have found out that scenes ran correctly when using Mozilla Firefox. I would suggest to give other browser a try if possible.
Another user mentioned that updating the Intel graphics driver have helped, but we are yet to confirm this.

In the meanwhile we are actively looking for a possible fix in Shapespark viewer.

Best regards

Thank you for your information and response.

I tried using firefox, but the same thing happened.

At this point, have you found any other solutions or ways to do it on your side?

Please check it.