Back to the Shapespark home page

Scene failed to load error on android phones

Hi,

I’m having ‘scene failed to load. Reload the page to retry’ error only on android devices.

Could you please give an advice on this?

Thank you

I am getting this error with on desktop as well. For me it’s caused by an ad blocker: one of the textures contains 300x600 phrase in the filename (Master_Bathroom_Wall_Main_300x600_tiled) and it turns out it’s a common ad banner size, so the ad blocker assumes the texture is a banner and blocks it from loading. Could you check if renaming the texture helps?

Thank you for your reply. However, it didn’t help. We re-named all the meterial file names but still get the same error. Any other solution?

Thank you in advance.

We actually renamed every material named ‘000x000’. But no luck. Please let me know if there’s any possible solutions.
It is the 2nd time we hve this probelm. So I’m wondering what causes this issue.

We cannot reproduce it on our Android phones? What phone and browser are you using? In particular, are you using a regular stand-alone browser like Chrome or Firefox? Or a browser built into some other application (eg. Messenger or WhatsApp)?

It’s a messenger browser but most of ss tours has had no problems like this. It’s only second tour that has this issue.

The messenger browser is called kakao talk.

Hi,
any thoughts or comments on this matter?

We don’t have a kakao talk to test, but our experience with built-in browsers in Facebook Messenger and WhatsApp is that they dedicate less memory to the browser process compared to the normal system browser. As this scene is quite large (3.2 million triangles), the most likely reason is that it fails to load due to the lack of memory. Perhaps decreasing the Max lightmaps setting from 2 to 1 and decreasing the Lightmap resolution setting to 75 will reduce the scene size enough to fix the problem.

We tried this but still no luck. And I’m not sure it’s the size of the model because we had bigger models which had no issues like this. For example, this model is much bigger and has many more items in it:
https://rowilab-tour.com/hoban/osan/84b.php#none

It only has problems with built-in browsers.

Any suggestions on the issue above?

Please let me know

This is strange indeed that the larger model loads, whereas the smaller one not. From the two links the larger one is served from your hosting and the smaller one from ours. Have you tried uploading the smaller scene to your hosting and loading it from there?

This actually solved the probelm. Thank you