Scene failed to load.Reload the page to retry

I can’t load the scene on my Android phone, it always pops up with the message
“Reload the page to retry.”.
How do I fix this problem please?

We cannot reproduce this issue on our Android phones. What phone and web browser are you using?

Meizu 17PRO phone, the browser on the screenshot is the built-in browser of WeChat, and the scene cannot be loaded in the Meizu default browser.

Can you navigate the scene while this error is displayed? Do you have Chrome installed and could you give it a try?

From our experience web browsers built into messaging apps like WeChat, WhatsApp or Facebook Messenger cannot open complex Shapespark scenes. Is there a room for geometry optimization in your scene? Reducing the number of triangles, leading to lower RAM consumption, might make the scene run in the built-in browsers.

Hello wojtek
I’ve tried many scenarios for Android phones in which the number of triangles is 3 million ≥ and ≤ 3 million triangles can’t be opened on shapespark, but I put the offline package on Tencent’s static cloud hosting, and Android phones can be opened on WeChat and built-in browser, so what is the problem? Could it be the problem of the server that comes with shapespark?
Testing down can rule out that it is not a problem with the number of triangle faces.

I’m also thinking of this issue a bit critical.

Shapespark scenes used to be opend in Android until last Summer.

Because of this issue, I tried different things and found out that Shapespark scenes can be opend in Android with using messenger apps if you host on your own server.

I don’t have the server right now so I can’t provide the link. But it worked definitely.

Thanks for the information. After trying an embedded browser, we’ve managed to reproduce the issue, and we are investigating it.

1 Like

Any update on this issue?

Hello wojtek!
Where is the progress on this issue, please? This issue is important to me, many of my visitors are partly on Android phones and it is impossible to force visitors to change their phones to access.

We have found out that browsers embedded in Android applications do not support Brotli file compression, unlike regular stand-alone Android browsers. We will be working on a workaround. It should be ready this week or early next week.

Okay, waiting for the update from your side.

Please let us know if it is solved :slight_smile: Thank you !

We’ve just deployed the fix. Cloud you try your scenes on mobile devices again?

It works! Great! Thank you so much for your hard work!

1 Like

I’m browsing the same again on my Android, error, please fix the bug, thanks!

Hello Wojciech !
I encountered the same problem again, the link has been sent to your email, please check

I’m experiencing this problem.
There is no problem when I’m using the shapespark hosting link.
But when I use the bundle function, and extract the outputed zipped file, file name of a specific textures was created with the same name. I think this causes the mini screen error at the center of the screen when I uploaded the bundle to our own host server.
I can go through all the scenes though but this error message is so distracting.
Do someone have a fix to this bug?

If you load the scene while having the Chrome developer tools open (F12), the Network tab will show in red color which file fails to load, this should help to fix the problem.


please solve this issue agian. It happens again

@Cob_KYU, we are investigating the issue.

1 Like