Back to the Shapespark home page

Scene with Video Texture doesn't Open in VR

Hi everyone, I have a scene with video texture playing on TV.When i load the scene in VR its laggy and once i click on VR mode its stuck on the loading screen for more than 15min. The scene is uploaded online on shapespark hosting.

I have also tried opening one of shapespark example scene with video texture and example scene also behaves the same way, doesn’t load.Here is the example scene i tried
https://demo.shapespark.com/shapespark-1_13-preview/

When i remove the video texture from the scene it works perfectly fine. Also its only for the online hosted scene as when i view the scene offline it works fine.Does anyone had this issue before?
Here is my scene which i tested:
https://3d.qubic.media/spacelab_low/

We can reproduce the issue, it is related to the WebVR -> WebXR switch. We are investigating it.

1 Like

Thank you @wojtek for investigating. Please drop a message here when you’ll find a workaround with the issue.

Also i am facing this issue when i try to enter in VR mode on phone(tried it on android phone). Here is the screenshot of error when i enter VR mode of any scene which had video texture in it.

@Mahesh, we’ve fixed this issue. The fix has been already deployed on our hosting.

1 Like