Back to the Shapespark home page

Shadows problems

Hi, I’ve several problems with shadows. How can I solve them?

The thin passage is very dark, and the “flood dark” post-processing filter treats the passage as an non-illuminated space, which leads to artifacts. I’d suggest to start from making the passage a bit brighter. Have you enabled ambient occlusion (in the “Bake” tab) for this scene?

I haven’t enabled ambient occlusion. If u want I can give u the link of this scene. https://pierugg8.shapespark.com/secolo024/

I see. Could you then enable the ambient occlusion and re-bake the scene?

image

Hi wojtek, unfortunately I have the same problem with the shadows of products and structure. I send u a screenshot and the link. Thank u so much if u can help me!


Shadows problems

The floor in your scene (pavi stanza 1) has Custom lightmap resolution set to 20, which means that one lightmap pixels covers 5 x 5cm square on the floor, leading to jagged shadows. I suggest to reset the global Lightmap resolution setting (Bake tab) to 75, and use lower lightmap resolution only for the objects for which shadows are less detailed (eg. external walls).

BTW, your scene has ~40M triangles, which is too much for an average mobile or desktop device. Have you considered optimizing geometry for some high-poly objects in the scene?

Hi @wojtek, unfortunately i can’t optimize the geometry. I have solved the shadows project for the structure but I still have problems whit product’s shadows. Thank u so much for all

What’s the effective lightmap resolution for the floor object? It looks like it’s much smaller that I have suggested (75). You can check it in the Objects tab. If the lightmap resolution of the floor was automatically reduced to fit the scene in Max lightmaps then it’s shown as the Auto lightmap resolution value.

Yes it’s 75 lightmap resolution but the auto lightmap resolution for the floor object is 23. Now I will reduce the auto lightmap to 23. I will send u the result. Thank u so much!!!

23 is too low lightmap resolution for the floor to avoid jagged edges. Instead, could you increase the number of lightmaps (Max ligthmaps) for the automatic reduction to be less aggresive? What’s your Max lightmaps setting now?

I try with 200 lighmatp resolution for the floor but it’s the same. The Max Lightmaps setting is 8 now. I give u my link to see it


Shadows

Thanks for providing the link to the scene. After analysing it, we’ve found that the lightmap resolution of the floor isn’t reduced because the scene doesn’t fit into the given number of lightmaps, but because the floor is a single large mesh, and this mesh cannot fit into a 4096x4096 lightmap using the requested resolution. For example, if the requested lightmap resolution for the floor is 75 [pixels per meter] then the maximum size of the floor that fits into a lightmap without reducing the resolution is 4096 / 75 = 54, so 54 x 54 meters.

Please cut your floor mesh into multiple meshes at room boundaries. Then, each mesh will be assigned to a separate lightmap, so the resolution reduction will be less aggressive.

1 Like