Back to the Shapespark home page

Splotchy at High Setting

Hi there community,

This is my 1st post so hello all :slight_smile:

I downloaded the trial a couple of days ago to test it for a potential job. It’s really great and I like it a lot but… even baking at high I still have spotches/blotches in my scene, especially on the ceiling. What am I doing wrong? I have 23 area lights, instanced and imported from Blender and converted to spotlights as I read that gives a cleaner bake. Any pointers would be fab.

Gallery Test

Thank you and once again, great application



The scene has two light sources for each light fixture: in addition do the spot lights below the fixtures, the bulbs inside of the fixtures are configured as emissive material with strength 200. Because this is very strong emissive light, close to the fixture geometry, and the fixtures have very small top holes through which the light escapes, these emissive bulbs are likely the source of noise on the ceiling.

Could you test baking with the Emissive setting for the bulbs disabled? You can make the bulbs emissive after the bakings finishes, so they are rendered as fully white, but are not treated as a light source during the baking.

In general lighting in interior scenes without access to windows is harder to setup. I’m not sure if the spots alone will be enough to achieve good effect. You may need some source of ambient lightning (for example some larger area lights or Ambient Occlusion).

Thank you for your feedback. I’ll try that.