Back to the Shapespark home page

Suddenly a pop-up error message came out

Suddenly a pop-up error message came out.
“Fatal error Failed to start HTTP server”

This error message suddenly appeared when the application was launched.
I used to be able to start it without any problems.

We have already added exclusions to security software and firewalls.
What is the cause?

Perhaps some other application is using a port that Shapespark application uses. If you open the following address in a web browser on your computer: http://localhost:5000 is there any site there?

@jan

http: // localhost: 5000
→ When you open this, “Search results” will appear. Is this normal?

We also sent you a log file by email.

Best regards.
Eri

It looks like some other application is using port 5000 on your machine, so Shapespark cannot reserve this port while starting.
Could you edit a configuration file C:\Users\<YOUR-USER>\AppData\Roaming\Shapespark\config.json?
At the beginning of this file, just after the opening {, add the following line:

 "port": 5001,

(trailing comma is important).
This will change the port that Shapespark reserves from 5000 to 5001.

EDIT: fixed quote characters (“port” instead of ‘port’)

Thanks for your reply.

I want to check it just in case.

Immediately after opening the uploaded file, add “‘port’: 5001,”.
Is the place to add correct after “https: //”?

Do I need to manually change to port 5001 whenever I can’t uninstall an app that uses port 5000?

Thank you

No, this setting needs to be stored in a location configuration file. Do you have a file: C:\Users\<YOUR-USER>\AppData\Roaming\Shapespark\config.json on your local disk?

@jan

Thank you.

I found it.
Can I open the file with Notepad?

{‘port’: 5001,
“devices”: [

Is there any problem with the addition as described above?

(Sorry, I can’t really verify because it’s the customer who’s having the problem.)

I’m sorry, I used wrong quote characters in my previous post (’ instead of "), it should be:

{“port”: 5001,
“devices”: [

You can edit the file in notepad and restart Shapespark afterwards.

1 Like

@jan
Hi,
I modified it as attached.
image

Unfortunately the error does not go away.
Is there any other workaround?

Thank you in advance.

If you go now to http://localhost:5001 with a web browser after starting Shapespark on a computer that has this problem, do you see the Shapespark scene list or still the "Search results” page mentioned in your previous post?

@jan

Thank you for your reply

I get an error screen when I access it.
http://localhost:5001

I’m very sorry about the delay.

Could you check if your Windows computer Device name includes national characters? Th Device name can be checked at Windows menu Start > Settings > System > About
See also: Rename your Windows 10 PC

Nationals character in the Device name could cause this kind of an error.