Back to the Shapespark home page

Switchable objects not showing in views

Hi,

in this scene https://meet.kazooie.io/cloud_210413/ we are experiencing issues with the switchable objects, I have programmed an objecto to show on all scenes except for one, but when entering the scene no objects is shown, even though the extension option “hide all on start” is not ticked.
Is this a bug? or something is wrong on our side.

The Groupo#13 object with the primary chair set is currently hidden in all the views. If you disable Custom hide in views for it, the primary chair set will be shown when the scene is started.

1 Like

But that will make it visible in every view, I would like to show group #162 in every view except for “7. Dinning” and if I disable custom hide in views then on scene 7. Dinning I will have two chair sets overlapping. I also noticed that when changing from view 7 to 8 when the camera starts moving all the chair sets dissapear…only to reapear when the viewer has come to a stop, seems like the execution order is: hide all switchable objects, move to next camera, show switchable objects.

The Custom hide in views option isn’t compatible with the Switch Objects extension, because both these features manage object visibility. So, in most cases, using these two features for the same object should be avoided.

1 Like