Textures resolution is low. need help

hi, i tried to export glb file into shapespark and turned off the auto compression and gpu compression and updated it. but it seems nothing happens there. i even tried to upload in fbx format and uploaded the 4k base colour texture but it also didn’t work.

this is the image in shapespark before and after turning of the auto compression options… where this is not the resolution i baked in blender. i also imported the glb to other empty blend file to check whether its baking error but it turned out to be a same 4k bake i did… i would really appreciate if theres a solution for this.

(I’m trying here to bake the lights itself in blender and export it to shapespark for high quality lights) (i also tried playing around various glb export settings in blender but it didn’t work)

UPDATE - i played around more and found out the big objects are not affecting like in this case the ceiling… i tried with a leaf with more detailed bake and it came out perfect when i turned off auto compression. only bigger objects are not updating…
(i also baked the book with high quality texture on it and it came perfect… and its 2k res. even the leaf is 2k res. the ceiling is 4k resolution… is that why its not updating because its 4k? )

Hello,
Maximum resolution for textures in Shapespark is 2K. What you can do is to divide this ceiling into 4 pieces, divide the texture in the same way and have 4 separate materials with 4 different textures to avoid compression.

hi, as you said i divided the ceiling into 4 pieces and materials too.


but then also it seems to be not working. this is not the resolution i wanted in shapespark and yet no matter what i do i don’t see any changes in resolution.

this image is from blender

and this in from shapespark.

the whole ceiling was baked in 2k each and had separate materials for each piece in shapespark where the auto compression was turned off.


blender


shapespark

Could you send me a link to your scene? it can be in a private message if it’s not public yet. I will take a look at it.