Back to the Shapespark home page

The function of left botton walking disabled when hidie and show a group of object


#1

after i cilck the second botton,and back to the house,the left botton walking is not work?it is a bug?how can i fix it.

look at this house.

https://lidingxing.shapespark.com/liushuibieshu/

i also find that show group objects after hiding,the phyisc is disabled,how to activate,how can i active it manually


#2

i have disabled the hiding function in object property,and i found the reason that left click disabled,when the physic disappear,the mouse can’t find the hitpoint on objects,and can’t positon coordinate。
now,there only one problem,how can i active physic??


#3

i have the point of this bug,i disabled the auto climb in camera.Physic is active after showing objects.i hope this small bug could fix in time.


#4

Beautiful scene!

By the second button do you mean the automatic tour button (in red)? :
house2

When the automatic tour is active (the button blinks) the camera position is updated automatically, so the left mouse walking and physics are disabled. You need to first disable the tour to enable the left mouse walking.


#5





hide to many objects or poly,may cause this bug。
hide one or two floor may be fine(some times is not),but hide all this sense must be cause this bug.

i also find strange bug,the objects not be choosen “walk on” ,the phyisc must be disappear after unhide.
the objects is choosen"walk on",the physic seems to move on z-axis after unhide;

by the way,i use 3dsmax2014.The sense contains many groups,and export to fbx format.


#6

Thank you for the detailed report. We were able to reproduce this bug and are investigating the cause.


#7

Please test again, we have fixed the bug for scenes uploaded to Shapespark hosting (for local scenes the fix will be included in the next Shapespark desktop app release).


#8

yeah~~
it’s fixed now,thank you.