Back to the Shapespark home page

스케치업에서 작업한 오브젝트가 깨집니다. The object I worked on in Sketchup breaks in Shapespark

안녕하세요. 현재 스케치업 2021과 Shapespark를 사용하는 유저입니다.
Hello, I’m a Sketchup 2021 and Shapespark user of South Corea.(Korea is right. But Marco Polo wrote Korea as Corea in his book.)

지난번에는 텍스쳐가 깨지는 문제를 적었고, 그 문제에 대한 해결법은 어느 정도 파악을 했습니다.
Last time, I wrote down the problem of texture breaking, and I figured out some of the solutions to that, a little.
그 방법 외에 다른 방법도 알고 싶지만, 그정도를 안 것으로도 충분히 도움이 되었습니다.
I’d like to know the other solutions about that, but but knowing that much was helpful enough.
댓글을 달아주신 wojtek님과 josephkim626님께 감사드립니다.
Thank you to “Wojtek” and “Josephkim626” for leaving comments.

그러나 지금은 또 다른 문제를 맞이했습니다.
However, now I faced another difficult problem.
이번엔 오브젝트 자체가 깨집니다.
This time, Object is breaking.

이번에 제가 맡은 일은 제 회사에서 기존에 만들던 공간에 열쇠를 추가하는 일이었습니다.
My job this time is to add a key to the space that my company made before.
다른 분이 열쇠를 만들어서 dae파일로 주고, 저는 그것을 최적화시켜서 스케치업에 올린 다음 Shapespark로 보내는 일을 맡았죠.
Someone give me a “dae” format file, and I was tasked with optimizing it, putting it on a Sketchup and sending it to Shapespark.
dae 파일을 최적화시키는 과정에서는 문제가 없었습니다. 설령 중요한 면들이 몇개가 없어져도 제가 일일히 다 메꿔주었고, 방향도 올바른 것을 다 확인했죠.(예전에 이 문제에 대해서도 여기에 적은 적이 있습니다.)
There was no problem in optimizing the dae file. Even if some of the important aspects are missing, I’ve filled them in, and I’ve checked all the correct directions (I’ve written about this before).

그런데, 여기서 문제가 발생합니다.
But, there is a problem here.
이번에도 회사의 작업물을 올리기는 곤란해서 다른 사진을 예시로 먼저 올리겠습니다.
It’s hard to upload the company’s work again this time, so I’ll upload another picture first as an example.

벤틀리키

저 Bently Smart Key를 보십시오.
Look at the Bently Smart Key.
저건 저의 작업물이 아니지만, 비슷해보여서 예시로 활용했습니다.
That’s not my work, but it looks similar, so I used that as a example.
스케치업에서 제가 저렇게 멋진 키를 제대로 만들었다고 가정해보겠습니다.
Let’s say I made such a great key like that in the Sketchup.
제가 면의 방향도 확인하고 올바르게 바로잡고 난 후에 Shapespark에 보냈다고 가정해 보겠습니다.
Let’s say I checked the direction of the side, corrected it correctly, and sent it to Shapespark.
이렇게 꼼꼼하게 확인하고 보내는데, Shapespark Editor에선 마치 마인 크래프트나 레고를 만든 것처럼 오브젝트가 깨져서 나옵니다.
I checked it carefully and sent it to Shapespark, but in Shapespark Editor, the object is broken like a Minecraft or Lego.

마인크래프트 키

팩맨을 만들었는데 영화 <픽셀>처럼 결과가 나왔다고 하면 이해하기 더 쉽겠네요.
It would be easier to understand if you made Pac-Man and the result came out like the movie .

더 이상한 것은 이 상태로 베이크하기 전에 프리뷰를 하면, 그 프리뷰 화면에선 아주 오브젝트가 멀쩡하게 잘 나온다는 겁니다.
그리고 베이크를 하면, 또 깨지죠. 에디터에서 계속 깨지는 것을 물론이고요.
What’s even weirder is that if you do a preview before baking in this state, the object comes out very well on that preview screen.
And when you bake, it breaks again. Of course, it keeps breaking in the editor.

이 문제의 해결법을 알아보기 위해 여러 키워드로 검색했습니다.
제가 포럼과 구글, 네이버, 유튜브에 “Shapesparke face break”, “Sketchup Shapespark Face crack”, “Shapespark object crash”, “Sketchup Shapespark object error”, “Shapespark object error” 등의 여러 키워드로 검색했으나, 결과를 찾을 수 없었습니다.
엉뚱한 결과가 나오거나 "No result"만 나옵니다. Shapespark 헬프 센터의 가이드 페이지를 봐도 마찬가지였습니다. 정말 결과가 없거나 제가 제대로 찾지 못하는 것이거나, 이 둘 중 하나겠지요.
그래서 여러분들께 도움을 요청합니다.
I searched with multiple keywords to find out how to solve this problem.
I searched forums, Google, Naver, and YouTube with keywords such as “Shapespark break”, “Sketchup Shapespark Facecrack”, “Shapespark object crash”, “Sketchup Shapespark object error”, and “Shapespark object error”, but I couldn’t find the results.
We get the wrong results, or we get only “Norsult”. It was the same when I looked at the guide page of Shapespark Help Center. Either there’s really no result or I don’t find it right.
So I’m asking for your help.

오브젝트가 깨지는 문제를 어떻게 해결할 수 있나요?
이 문제의 원인과 해결방법을 알고싶습니다.
만약 정석을 알려주기 힘들다면, 편법이라도 확실히 될만한 방법을 알고 싶습니다.
How can I solve the problem of breaking an object?
I want to know the cause and solution of this problem.
If it’s hard to tell you the standard, I’d like to know a way to make sure that it’s an expedient.

부탁합니다. 도와주세요.
Please~! Somebody Help Me~!!

2021/06/23 13:40
작업사진을 허락 받고 올립니다.
I upload the work picture with permission.

먼저, Sketchup에서는 면 방향에 문제가 없었습니다.
First of all, there was no problem with the face direction in Sketchup.

그러나, Shapespark로 보내면 Editor에서 깨지죠. 이건 베이크를 하고 난 후에도 마찬가지입니다.
However, I sent it to Shapespark and broke it in the Editor. It’s the same after baking.

그런데, 베이크를 하기 전에 프리뷰를 했을 땐 멀쩡했습니다.
But, it was fine when I previewed it before bakng.

과연 뭐가 문제일까요?
What is the problem?!

그리고, 혹시나해서 크기를 키워봤고, 어느 정도는 나아지긴 했습니다만, 우리는 크기를 키우지 않는 범위 내에서 해결해야합니다.
And, just in case this works, I’ve grown the size of the object, and it’s improved to some extent, but we have to solve this problem without increasing the size.
크기 문제가 진짜 문제인가요?!
Is the size problem a real problem?!
또, 오브젝트의 크기를 키우는 것 외엔 방법이 없나요?!
Also, is there any other way but to increase the size of the object?!


Please~!!!
Help~!!!
Somebody Help Me~!!!

I have the same problem now, objects and textures are broken after importing from 3ds max. I tried to set everything everywhere to get rid of it but no success, object looks the same way as the key in the example above. In preview it is shown correctly. Thanks for a help.

Because most of the Shapespark scenes do not include such detailed high resolution objects, Shapespark default geometry compression parameters do not work well for them. By default Shapespark uses vertex accuracy of 0.5 millimeter, so objects that require smaller details will look ‘Minecrafty’. To improve this, please set the vertexAccuracy setting to some very low value, for example 0.000001.

This post explains where to set this value.

Thanks for hint, it solved my problem.