Back to the Shapespark home page

Unable to see shadows

Hello everyone,

For some unknown reasons I am unable to see shadows falling from external environment in my space when I bake it.

Can someone please help me here?

Hi @Parin_Karia & welcome to the forum.

Is this scene uploaded? Could you share a link to it? If the scene isn’t public, you can send me the link via forum’s private message or via email to support@shapespark.com

Hi @wojtek ,

Scene : https://tour.virtualhomes.in/residential_sample_project/

Can you check out this scene and tell me how do I increase the darkness of the shadows ? They appear to be very light in color and are barely noticeable.

@Parin_Karia,

The net curtain has opacity = 0.7 in your scene, so it blocks most of the sun & sky light. You can lower it, even to 0, for the time of baking, and the increase it back.

The window glass material is also more opaque than it should be. Try using opacity = 0.05 for it.

The sun is at the zenith, so it’s not illuminating the room. Orient the sun so that it shines through the windows. Also, because of the increased sun size (0.09) the shadows coming from sun are very soft. Revert the size to the default value 0.02.

When you let more natural light in, you will be able to turn the ambient occlusion off, which should lead to a bit more realistic lighting.

@nishantambekar, the sky strength you use is too high for an exterior scene. Try lowering it to 1. Disabling ambient occlusion should also help to obtain nicer shadows.

I tried doing as suggested, but the problem with that is the interior of the building (inside an apartment) is not getting any light at all, and has turned completely black/dark.

I see. If you want to present both the exteriors and interiors then the Camera volumes feature will help you to use different exposure & gamma settings inside and outside. Please take a look at this post: Sun brightness accuracy?

Thanks for your help. Camera Volumes have solved my problem