Back to the Shapespark home page

Unfinished bundle process stops from editing the scene

I started a “bundle scene” and stopped the process during the operation. After that, I wasn’t able to edit the scene. It didn’t open the editor. Only after I restarted and finished the bundle process of the scene I was able to edit it again. Maybe there is a way to fix this.

This is a problem caused by bundle, upload and bake doing modifications to the scene that take several steps. If the process is canceled between such steps, the scene can become corrupted and may require running bundle again to fix the format.

For example texture atlas generation is such several steps process, and a scene with atlases partially generated can fail to load.

We are thinking of a right approach for fixing this problem. Perhaps all these operations should work on a temporary copy of a scene.

Hi @Jan

We have this problem again and I cannot remember how or if we solved this last time. Was there a trick to get the scene back to work?

@tim, have you tried running bundling and letting it finish the job? It should resolve the issue if this is related to interrupted bundling or upload.

It it doesn’t help could you please pack the scene and send it to us for analysis?

Hey @wojtek
That worked. We can open the scene again. Thank you.