Back to the Shapespark home page

UVW Mapping from 3ds Max

I am having a problem with the UV mapping of textures from 3ds max 2020, I’ve read in multiple posts that you must use a UVW Map and thats what i’m doing, only when I get the material looking correct in Max, export and FBX and Import into Shapespark, the texture is tiny and has tiled across the surface rather than filling it.
I have adjusted real world scale to both on and off in the default preferences as well as in the material and in the UVW modifier and combinations off all 3 but no change. I have tried exporting with a scale factor of 1 and a scale factor of 0.01 and nothing changes.
The only thing I am able to do is really over scale my texture in max so it comes out okay in Shapespark but that isn’t sustainable because I will have no idea how everything is going to map.

On my other computer where 3dsMax 2017 is installed, the mapping works perfectly, I have compared all settings between the two and cant find anything. I even took my 207 model, opened it in 2020 and imported it into shapespark and had the same problem seen below. Has anyone had a similar issue? Is this a bug or something im missing?

What Map Channel are you using for this bitmap? Could you take a look at the Some textures have wrong scale/tiling section of our 3ds Max export guide if it applies to your setup?

The Map Channel is 1 but I have just compared my settings to someone else in this forum
Shapespark Errors 14

And noticed that I have 0.01 in tiling where they have 1.0, this is then causing me to change my UVW map settings to something extreme, then the tiling in the material gets ignored when exporting to FBX and i’m left with the extreme UVW map. Could this be the case? I will test this now

Thank you Wojtek

@sachaandraos, yes I think it might be the case. Could you use the tiling parameters of the UVW map modifier instead of the bitmap options?

That’s working now thanks a lot Wojtek

1 Like