VR Scaling issue

Greetings everyone,

I am very pleased with Shapespark, but I am currently experiencing a scaling issue with VR. Although my scenes are accurately scaled, I have noticed that the world appears to be scaled down by 1.5 to 2 times. This has discouraged clients from utilizing it, as they have commented that it displays their projects in a smaller scale, thereby defeating the marketing purpose.

Unfortunately, there are no VR scale settings that I can adjust. Do you have any suggestions on how I can ensure that the world is presented in the correct scale?

Which VR headset are you using? Would it be possible for you to share a link to your scene with us, so we analyzed the issue on our end? If the scene is not public, you can send the link the forum’s private message

Hi, Wojtek

Thank you for reaching out,
I am using Quest 2, links in the PM.

1 Like

Hi @wojtek,
I have a similar problem, I’m trying to show a client the possibilities of shapespark VR but I have models that do scale correctly and others that don’t, check it out:

model with correct scale (roughly)

Models with reduced scale
Link to Kazooie in the shapespark website -I can’t copy it- (this is the most curious, it looks like a dollhouse!)
3D scene#autoplay&help

My kit is
windows Mixed Reality
Samsung Oddissey lenses (first generation)

How can I adjust the scale of the paths? is there any way?

There is a fundamental issue with scale in VR… in 2024. Just checking in, this leaves us with using other tools to post our VR content.

You can control the perceived scene scaling in VR by changing the camera height (‘Height to ground’):

You just have to enable ‘Auto climb’ and make sure that all walking surfaces are marked as such (‘Walk on’):