Water shader not working

Hi just posting to let you know that the water shader is not working. Check out the pool outside.

Cheers JD

Hi,
Thanks for the report. We have a fix for this issue ready, we should be able to release it today.

This problem should now be fixed on the cloud.
It will be fixed in the desktop version next week.

Hi,
The water shader is still not working on my end in the cloud. :slight_smile:

You would have to open this scene in the cloud editor and re-create the water material. Then it will start working. You can also just wait for the full release next week.
Sorry for the inconvenience.
Have a nice weekend :slight_smile:

1 Like

We’ve just released Shapespark 3.0.4 with fixed water.
Unfortunately materials in which water broke have to be recreated (for example by converting to standard material and back to water material).

This works in the editor but as soon as I publish, there’s no movement in the water again both in editor and in preview :frowning:

Hi,
Could you provide a link to the scene with broken water?
You can put it here or send it to us via personal message.

1 Like

By all means, thanks :slight_smile:

PM works for me, it’s not yet that much of a public project.

Although, I must admit, it’s a newly updated duplicate of a scene that was initially uploaded in March.

To fix the water, you just have to change the material type to standard and then to water back again.

Thanks, but that’s not enough. As soon as I publish the water becomes still plane and not-moving again :frowning:

Sorry to hear that :(. You can try doing this:

  • change water material to standard
  • save the scene
  • reload the editor
  • change the material to water
  • save the scene
  • upload the scene again to the cloud

I tried it on my side and it worked for me.
Let me know if this helped, if not, I will look into this problem again.

I tried all kinds of methods and that what you mentioned as well.

Also tried to upload the whole scene from scratch and not only update the previous one which had the correct settings. Still same issue. Water works nicely, but straight after ‘Publish’ → water is not moving again, static and still as one can be :confused:

Hi… I know what fixed the problem for me last month was I had to change the water in the editor to standard and then back to water material in the Cloud editor not the desktop editor. Try logging into the cloud editor and give that a try. It worked for me last month. Not sure if it was the same error for me as it is for you today.

Hmm, Cloud editor is all I use, actually :confused: But thanks! :slight_smile:

Hi,
I reproduced this problem on my end. It seems that the fix for broken water wasn’t pushed to our cloud worker, which is being run during publish. We will fix this issue in the next release (it should happen in about 2 weeks or so).
Generally if you could only edit the scene in the desktop version and avoid using publish, then the water should work.
Once again sorry for the inconvenience.

I just realized the same.
Even water on a Blender Cube loaded as a new scene after log out and log in to shapespark cloud didn’t work.

Please reply when the cloud editor has been fixed :slight_smile:

We’ve just uploaded a new version of the cloud editor and this issue should now be fixed :slight_smile: