Back to the Shapespark home page

Web textures not working


#1

Hi.
i know that this topic has already been spoken but am wondering if it someone has solve this problems?
currently am having the same problem with a large scale project of a house and dont know what to do…
anyone has work it out??? pls help :joy::joy:

Grettings¡¡¡


#2

Could you explain in a little more detail? Not sure I really know what you are asking. Maybe this model will give you some ideas. Carwash


#3

@Antonio_Perez, do you mean that you get the “failed to generate web textures” error? Could you locate the scene folder on your local hard drive inside the Documents\Shapespark folder, compress it, and send the archive to support@shapespark.com (eg. via WeTransfer)?


#4

Hi
Yes i get the “Failed to generate web textures” message
and i would send you my files but i doesnt even generates a folder with the files in my "Documents"
what can i do??


#5

Could you check one more time if there is a Shapespark folder inside your Documents folder? If so, does it have a subfolder named like your scene?


#6

i checked and theres nothing … i just get the “Failed to generate textures” error and i doesnt generates a folder in my documents :L
what can i do?


#7

@Antonio_Perez, what is the name of the scene for which you get this error?


#8

the name of project ( wich is made in sketchup) is: “3D MAPACHES PARA SHAPESPARK-PRUEBA” translateted in english would be " 3D mapaches ( name of the colony) for shapespark-test"


#9

Oh, I see, you get the error while exporting the scene from SketchUp to Shapespark, while I was thinking that it occurs while uploading the scene from Shapespark application to the Internet.

in this case would it be possible to share the SketchUp file with support@shapespark.com (eg. via https://wetransfer.com ), so that we investigated the problem?


#10

sure i’ll send it now
Thanks a lot :smiley:


#11

I JUST SEND IT TO THE ADDRES YOU GAVE ME :smiley:


#12

@Antonio_Perez,

I’ve tried to export of the SU file you sent us and it worked. So, it seems the error is not general, but somehow related to your particular Shapespark installation.

To help us further investigate the issue may we have some questions?

  • What SU version are you using?
  • Are you exporting the SU model using the Create a new scene option? What name do you choose for the scene?
  • Could you send us a problem report from the Help & Support tab of the main Shapespark window just after the error occurs? It will send us the Shapespark logs which may give more information about the issue.

#13

1- By “SU” what do you mean ¿ SHAPESPARK?..

2- YES. i use the create new scene option… then … shapespark gives me the choisse to pick a name and i just let the lets say… “default name” the program gives me … after this… the program starts to export the model and textures and after hmmm 5 minutes the error appers …


#14

I was thinking maybe is also because of the name of my scene…speaking about html probles with letters like " - / ñ " simbols or letters that are known to give probles with html links … soo i changed my sketchup file name for a more simple one as you can see , and also at the time the exporter asked me “what name would i like to adress my scene” i type the same name of the sketchup file… and i didnt worked :expressionless::persevere::disappointed_relieved:


#15

Thank you for the information.

By SU I meant SketchUp: what SketchUp version are you using. But now I see it from the screnshot in the post above: 2017. The version I’ve exported the scene with success was 2018. I will try again with SketchUp 2017 to check if it matters.

Right, we are also suspecting some problems related to non-Latin characters in directories or texture file names, however we do not have anything concrete yet.

Can you send us the problem report from the “Help & Support” tab of the main Shapespark window? The logs attached to the report should give us more information about the problem.


Identify problematic textures?
#16

OK.
i’ll be waiting for a reply, and sending my report
Thanks¡¡¡


#17

Thanks for sending the problem report. The logs attached to the report indeed gave us more information about the problem.

The problem occurs when textures contained in your SketchUp model are extracted from the model and written to files to allow Shapespark to pick the textures during the SketchUp model import. For one BMP texture the resulting file is corrupted. We are not sure what the cause is, especially that it happens on your computer while it does not happen on ours. One potential reason is that there is a bug inside SketchUp related to extracting textures (do you have the most recent update of the SketchUp 2017?)

The good information is that there is a workaround. If you remove the texture from the material called leaf in your SketchUp model, or if you replace this texture with a JPG version, the export should work. Please take a look at the following screenshot to find out which material is problematic:

problematic-leaf-material

Please let us know if it helped.

In the future we will make Shapespark ignore corrupted texture files rather than cause the SketchUp -> Shapespark export to fail.


#18

IT WORKEDDDD OH SWEET LORD THANK YOU SO MUCH ¡¡¡¡

THANKS THANKSSS A LOT :smile: