Back to the Shapespark home page

WebVR error with Chrome and Edge (improved... and looks amazing!)


#1

Hi @wojtek and @jan, I have a project that I must visualize with WebVR. At the moment i’m doing some tests and I have not been able to see it correctly.
With Edge the scene upload fine but appear with big black areas
With Chrome the scene simply does not load and steam generates an error: chrome.exe error

https://all360.shapespark.com/vp_asamblea_sala_vip400/

I have Acer Aspire 7 Laptop Intel Core i7-8750H 2.20GHz 16GB Ram GeForce GTX 1060 6GB, Samsun hdm Odyssey headsets, chrome with VR flags enables and Edge upgraded

What can I do?

Some Q:
Can I use shapespark viewer with VR headsets?
Edge always do the job but with lack of quality
Chrome, when it manages to load the scene, it has a better quality but I have almost never managed to load a scene VR chrome!

BTW: I have not problem at all in VR mode with cellphones, this problems that I mention above only happens with VR mode on Hmd Odyssey headset.


#2

We will bring our Microsoft Mixed Reality headset to the office tomorrow and test your scene.

At the time that we were adding support for the Mixed Reality, these devices were supported only by the Edge browser. It looks like Chrome is working on adding support, but it doesn’t seem to be available in the released versions of Chrome: https://9to5google.com/2019/01/23/google-chrome-windows-mixed-reality-headsets/


#3

Thanks @Jan, I hope you can help me with this issue. I really need to show this job in window mixed reality headsets! Ask me whatever you need to cooperate and move forward! :muscle:t3:


#4

We see the same black ceiling problem with our Acer headset, looking what is the cause of this.


#5

The Edge problem is fixed, please try again.


#6

Thanks @Jan looks very very well!
I take the opportunity to consult: I feel that I am a little higher than normal when I use the VRheadsets, how can I change the height of vision?


#7

For scenes without ground configured and without the camera auto climb option enabled, the height is the same as it is in the view from which you are switching to VR. You can adjust it with PgUp and PgDown (this works also in VR mode).

For scenes with ground and the camera auto climb option enabled, the height reported by the HMD sensors should be used.


#8

Thanks @jan for your quick and accurate answers. As soon as I finish the scene I will share it in the forum!

Regarding the height of the view, this link show you how to set up the height of view in Windows Mixed Reality headsets: