Back to the Shapespark home page

Your advices - full house


#1

Hello. i have modelise a full house with sketchup (interior/exterior). i have some problem: the size of sketchup file (600 MO) and the bake is more 1 day (after baking, the local folder is 1,2 Go). I mus reduce the size of light if not I receive an error. When i try to visit, i have some problems: light, slow movement. Have you advices for me to optimize my project.
The link: https://fredin.shapespark.com/villa-temoin2/

Thank you in advance

Regards

frederic


#2

Hi @fredin

Nice scene, thanks for sharing!

The two most important things to optimize the size of the scene and the baking time are:

  1. Currently your scene has more than 6M triangles, so it requires rather a powerful graphics card to achieve good frame rate (especially in the edit mode). To decrease the number of triangles you can replace high-poly objects with low-poly alternatives. The list of objects in the Objects tab will help you to identify the most complex objects, because it is sorted by the triangle count (at each hierarchy level), and it shows the triangle count together with the number of instances of the object. For example:
    • Each lavenderer bush has 140k triangles, and there are 20 bushes, which gives a total of 2,8M triangles.
    • Each curtain set on the upper floor has 80k triangles and there are 8 such sets, which gives a total of 640k triangles.
  2. Use low Custom lightmap resolution (eg. 10) for the terrain around the building, and perhaps also for the vegatation on the terrain. Currently only the wall enclosing the terrain has custom lightmap resolution. If you put all these “terrain objects” in one SketchUp group, you would be able to set the custom lightmap resolution for the whole group with one setting.

#3

Hi Wojtek, thank you for your answer. i will test your advices and give a feedback as soon as possible. have a nice weekend :slight_smile: