Back to the Shapespark home page

Your graphics card does not have... texture sizes 4096 need to be supported

Hello, my client send me this message. He received it on older Samsung phone (d/k the model yet).
Not sure if my textures are that big… also I was told that Shapespark resizes textures for mobile…
What might have caused this issue?

Actually, I have found the lightmap in \img\large\std folder. I tried to manually resize it but this was not the solution :smiley:

What if I set lightmap resolution to something about 50, would it generate smaller lightmap?
Or it won’t work on older devices anyway?

What might be the limit for older devices (I’m planning to use an HDRI map so need to know if f.ex. 3500 px will do or it has to be no more than 2048)


This is very unlucky. According to 99.9 percent of devices support 4096 texture size, so we decided to use such size for lightmaps (using 2048 would result in 4x more lightmap textures switches, so lower FPS).

Setting lower lightmap resolution will not help, because it will likely generate for example 4096x1024 lightmap.

All other textures are at most 2048x2048 on mobile, so we are thinking about supporting such devices by not loading lightmap at all (resulting in very basic quality).

1 Like